No sound in i386 Wine Staging

Hello everyone.

About a month ago I switched from using Linux for about 5-10 years over to FreeBSD and I can say that I really like the stability I get from my FreeBSD installation. Sometimes I miss some of the features I can get on Linux but in most cases I can find an alternative and I like the stability over the features.

I have had some troubles with the migration but with DuckDuckGo and enough time I have been able to learn new stuff and figure things out. Now I have sound (which was difficult to get working in the beginning)

Now I have an issue I can't find a solution for on the web.
I would like to watch Netflix and have tried to install the emulators/pipelight plugin from the ports tree (as there is no Chrome build or Widevine for FreeBSD) to use Silverlight and Widevine and I can get the video to play but I have no sound though I have sound everywhere else. I thought it had something to do with Pipelight/Silverlight but then I tried to install x86 Firefox Windows version in a Wine prefix and browse to youtube where I have no sound neither. When the video starts I hear a "scratch" sound and then both video and audio playback stops/hangs.

anders@anders /u/p/e/pipelight> cat /dev/sndstat
Installed devices:
pcm0: <Realtek ALC269 (Analog 2.0+HP/2.0)> (play/rec) default
pcm1: <Realtek ALC269 (Internal Analog Mic)> (rec)
pcm2: <Intel Panther Point (HDMI/DP 8ch)> (play)
No devices installed from userspace.

I use FreeBSD 11.0-p2.

Does anyone have any suggestions?
If you need any info then tell me and I will post it for you.

Sorry if my English is a little bad. I am not a fluent or native speaker.

Thanks in advance.