Solved No screens found (EE)

calo

New Member


Messages: 2

You'll be bored to read "always" the same problem, but have installed FreeBSD on my old Laptop with two graphic cards:
Code:
pciconf -lv
vgapci0@pci0:2:0:0:     class=0x030000 card=0x02711028 chip=0x06e810de rev=0xa1 hdr=0x00
    vendor     = 'NVIDIA Corporation'
    device     = 'G98M [GeForce 9200M GS]'
    class      = display
    subclass   = VGA
vgapci1@pci0:3:0:0:     class=0x030000 card=0x02711028 chip=0x086610de rev=0xb1 hdr=0x00
    vendor     = 'NVIDIA Corporation'
    device     = 'C79 [GeForce 9400M G]'
    class      = display
    subclass   = VGA
I have also installed
Code:
pkg install xorg xfce slim
pkg install x11/nvidia-driver-340
my xorg.conf (generated with nvidia-xconfig --multigpu=on --sli=on
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 415.25


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AddARGBGLXVisuals" "True"
    Option         "MultiGPU" "on"
    Option         "SLI" "on"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
/etc/rc.conf
Code:
moused_enable="YES"
dbus_enable="YES"
#hald_enable="YES"
slim_enable="YES"
/boot/loader.conf
Code:
nvidia_load="YES"
but I still getting an error when execute startx. log:
Code:
[   308.872]
X.Org X Server 1.18.4
Release Date: 2016-07-19
[   308.872] X Protocol Version 11, Revision 0
[   308.872] Build Operating System: FreeBSD 12.0-RELEASE-p3 amd64
[   308.872] Current Operating System: FreeBSD fbsd 12.0-RELEASE FreeBSD 12.0-RELEASE r341666 GENERIC amd64
[   308.873] Build Date: 07 February 2019  09:16:52AM
[   308.873]
[   308.873] Current version of pixman: 0.34.0
[   308.873]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[   308.873] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   308.874] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Mar 12 08:41:10 2019
[   308.874] (==) Using config file: "/etc/X11/xorg.conf"
[   308.874] (==) Using config directory: "/usr/local/etc/X11/xorg.conf.d"
[   308.875] (==) ServerLayout "Layout0"
[   308.875] (**) |-->Screen "Screen0" (0)
[   308.875] (**) |   |-->Monitor "Monitor0"
[   308.875] (**) |   |-->Device "Device0"
[   308.875] (**) |   |-->GPUDevice "Device0"
[   308.875] (**) |-->Input Device "Keyboard0"
[   308.875] (**) |-->Input Device "Mouse0"
[   308.875] (==) Automatically adding devices
[   308.875] (==) Automatically enabling devices
[   308.875] (==) Not automatically adding GPU devices
[   308.875] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   308.876] (==) FontPath set to:
        /usr/local/share/fonts/misc/,
        /usr/local/share/fonts/TTF/,
        /usr/local/share/fonts/OTF/,
        /usr/local/share/fonts/Type1/,
        /usr/local/share/fonts/100dpi/,
        /usr/local/share/fonts/75dpi/
[   308.876] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[   308.876] (**) Extension "Composite" is enabled
[   308.876] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   308.876] (WW) Disabling Keyboard0
[   308.876] (WW) Disabling Mouse0
[   308.876] (II) Loader magic: 0x413020
[   308.876] (II) Module ABI versions:
[   308.876]    X.Org ANSI C Emulation: 0.4
[   308.876]    X.Org Video Driver: 20.0
[   308.876]    X.Org XInput driver : 22.1
[   308.876]    X.Org Server Extension : 9.0
[   308.877] (!!) More than one possible primary device found
[   308.877] (--) PCI: (0:2:0:0) 10de:06e8:1028:0271 rev 161, Mem @ 0xae000000/16777216, 0xd0000000/268435456, 0xac000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/65536
[   308.877] (--) PCI: (0:3:0:0) 10de:0866:1028:0271 rev 177, Mem @ 0xaa000000/16777216, 0xb0000000/268435456, 0xcc000000/33554432, I/O @ 0x00005000/128, BIOS @ 0x????????/65536
[   308.878] (II) LoadModule: "glx"
[   308.878] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[   308.914] (II) Module glx: vendor="NVIDIA Corporation"
[   308.914]    compiled for 4.0.2, module version = 1.0.0
[   308.914]    Module class: X.Org Server Extension
[   308.914] (II) NVIDIA GLX Module  340.107  Thu May 24 21:25:00 PDT 2018
[   308.914] (II) LoadModule: "nvidia"
[   308.915] (II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
[   308.916] (II) Module nvidia: vendor="NVIDIA Corporation"
[   308.916]    compiled for 4.0.2, module version = 1.0.0
[   308.916]    Module class: X.Org Video Driver
[   308.916] (II) NVIDIA dlloader X Driver  340.107  Thu May 24 21:04:45 PDT 2018
[   308.916] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   308.916] (--) Using syscons driver with X support (version 2.0)
[   308.916] (--) using VT number 9

[   308.923] (EE) No devices detected.
[   308.923] (EE)
Fatal server error:
[   308.924] (EE) no screens found(EE)
[   308.924] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[   308.924] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   308.924] (EE)
[   308.940] (EE) Server terminated with error (1). Closing log file.
can somebody help me or just give me a hint :)
 

tedbell

Active Member

Reaction score: 71
Messages: 172

Try getting rid of the line in /boot/loader.conf and add these to /etc/rc.conf instead:

Code:
kld_list="nvidia nvidia-modeset"
nvidia_name="nvidia"
nvidia_modeset_name="nvidia-modeset"
Also make sure you have the FreeBSD source tree and if you compiled it with linux have that enabled in rc.conf.
 

shkhln

Aspiring Daemon

Reaction score: 275
Messages: 846

Is there something called "Hybrid SLI" in the bios settings? Turn it off.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,876
Messages: 31,140

If I recall correctly the legacy NVidia driver (340) doesn't have nvidia-modeset.

Because you have two cards you need to supply the BusID:
Code:
Section "Device"
  Identifier "Device0"
  Driver "nvidia"
  BusID "PCI:3:0:0"
  VendorName "NVIDIA Corporation"
EndSection
 
OP
OP
C

calo

New Member


Messages: 2

Thank you for your answers.
I don't know how, but at some point I was on this site: https://www.freebsd.org/doc/handbook/linuxemu-lbc-install.html
I added linux_enable="YES", reinstall nvidia-driver and added
Code:
Section "Device"
  Identifier "Device0"
  Driver "nvidia"
  BusID "PCI:3:0:0"
  VendorName "NVIDIA Corporation"
EndSection
now it works :)

Do I understand it in the right manner: is it working with only with one GPU?
 
Top