No pcm device during probing, no audio in /dev

hruodr

Aspiring Daemon

Reaction score: 276
Messages: 887

dmesg gives:

Code:
ata1: <ATA channel> at channel 1 on atapci0
pci0: <multimedia, audio> at device 15.3 (no driver attached)
ohci0: <OHCI (generic) USB controller> mem 0xeff00000-0xeff00fff irq 11 at device 15.4 on pci0
usbus0 on ohci0
ehci0: <AMD CS5536 (Geode) USB 2.0 controller> mem 0xefa00000-0xefa00fff irq 11 at device 15.5 on pci0

Any hint, what to do? :)
 
Last edited by a moderator:
OP
H

hruodr

Aspiring Daemon

Reaction score: 276
Messages: 887

Alexander88207, that is what I get:

Code:
# pciconf -lv
hostb0@pci0:0:1:0:      class=0x060000 card=0x20801022 chip=0x20801022 rev=0x31 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD]'
    device     = 'CS5536 [Geode companion] Host Bridge'
    class      = bridge
    subclass   = HOST-PCI
vgapci0@pci0:0:1:1:     class=0x030000 card=0x20811022 chip=0x20811022 rev=0x00 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD]'
    device     = 'Geode LX Video'
    class      = display
    subclass   = VGA
none0@pci0:0:1:2:       class=0x101000 card=0x20821022 chip=0x20821022 rev=0x00 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD]'
    device     = 'Geode LX AES Security Block'
    class      = encrypt/decrypt
re0@pci0:0:13:0:        class=0x020000 card=0x816910ec chip=0x816910ec rev=0x10 hdr=0x00
    vendor     = 'Realtek Semiconductor Co., Ltd.'
    device     = 'RTL8169 PCI Gigabit Ethernet Controller'
    class      = network
    subclass   = ethernet
isab0@pci0:0:15:0:      class=0x060100 card=0x20901022 chip=0x20901022 rev=0x03 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD]'
    device     = 'CS5536 [Geode companion] ISA'
    class      = bridge
    subclass   = PCI-ISA
atapci0@pci0:0:15:2:    class=0x010180 card=0x209a1022 chip=0x209a1022 rev=0x01 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD]'
    device     = 'CS5536 [Geode companion] IDE'
    class      = mass storage
    subclass   = ATA
none1@pci0:0:15:3:      class=0x040100 card=0x20931022 chip=0x20931022 rev=0x01 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD]'
    device     = 'CS5536 [Geode companion] Audio'
    class      = multimedia
    subclass   = audio
ohci0@pci0:0:15:4:      class=0x0c0310 card=0x20941022 chip=0x20941022 rev=0x02 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD]'
    device     = 'CS5536 [Geode companion] OHC'
    class      = serial bus
    subclass   = USB
ehci0@pci0:0:15:5:      class=0x0c0320 card=0x20951022 chip=0x20951022 rev=0x02 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD]'
    device     = 'CS5536 [Geode companion] EHC'
    class      = serial bus
    subclass   = USB
#
 
OP
H

hruodr

Aspiring Daemon

Reaction score: 276
Messages: 887

Yes, I suspected a special driver is necessary. I will try it tomorrow.
 
Top