Solved No Mouse Or Keyboard In X

Just upgraded all my packages.

I can start X, but with no mouse or keyboard.

13.1-RELEASE
X.Org X Server 1.20.14

Code:
X.Org X Server 1.20.14
X Protocol Version 11, Revision 0
[   105.897] Build Operating System: FreeBSD 13.1-SYNTH amd64 
[   105.897] Current Operating System: FreeBSD ochre.local.minium.com 13.1-RELEASE FreeBSD 13.1-RELEASE releng/13.1-n250148-fc952ac2212 GENERIC amd64
[   105.897] Build Date: 27 July 2022  09:40:44AM
[   105.897]  
[   105.897] Current version of pixman: 0.40.0
[   105.897]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   105.897] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   105.897] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jul 28 08:26:47 2022
[   105.897] (==) Using config directory: "/usr/local/etc/X11/xorg.conf.d"
[   105.897] (==) Using system config directory "/usr/local/share/X11/xorg.conf.d"
[   105.897] (==) No Layout section.  Using the first Screen section.
[   105.897] (==) No screen section available. Using defaults.
[   105.897] (**) |-->Screen "Default Screen Section" (0)
[   105.897] (**) |   |-->Monitor "<default monitor>"
[   105.897] (==) No device specified for screen "Default Screen Section".
    Using the first device section listed.
[   105.897] (**) |   |-->Device "Card0"
[   105.897] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[   105.897] (==) Automatically adding devices
[   105.897] (==) Automatically enabling devices
[   105.897] (==) Not automatically adding GPU devices
[   105.897] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   105.897] (==) FontPath set to:
    /usr/local/share/fonts/misc/,
    /usr/local/share/fonts/TTF/,
    /usr/local/share/fonts/OTF/,
    /usr/local/share/fonts/Type1/,
    /usr/local/share/fonts/100dpi/,
    /usr/local/share/fonts/75dpi/,
    catalogue:/usr/local/etc/X11/fontpath.d
[   105.897] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[   105.897] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[   105.897] (II) Loader magic: 0x433270
[   105.897] (II) Module ABI versions:
[   105.897]     X.Org ANSI C Emulation: 0.4
[   105.897]     X.Org Video Driver: 24.1
[   105.897]     X.Org XInput driver : 24.1
[   105.897]     X.Org Server Extension : 10.0
[   105.897] (!!) More than one possible primary device found
[   105.897] (--) PCI: (4@0:0:0) 1a03:2000:15d9:1b28 rev 65, Mem @ 0xa4000000/16777216, 0xa5000000/131072, I/O @ 0x00003000/128, BIOS @ 0x????????/65536
[   105.897] (--) PCI: (83@0:0:0) 10de:1cb6:10de:1264 rev 161, Mem @ 0xcf000000/16777216, 0x38bfe0000000/268435456, 0x38bff0000000/33554432, I/O @ 0x00009000/128, BIOS @ 0x????????/65536
[   105.897] (II) LoadModule: "glx"
[   105.897] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[   105.897] (II) Module glx: vendor="X.Org Foundation"
[   105.897]     compiled for 1.20.14, module version = 1.0.0
[   105.897]     ABI class: X.Org Server Extension, version 10.0
[   105.897] (II) LoadModule: "nvidia"
[   105.897] (II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
[   105.899] (II) Module nvidia: vendor="NVIDIA Corporation"
[   105.899]     compiled for 1.6.99.901, module version = 1.0.0
[   105.899]     Module class: X.Org Video Driver
[   105.899] (II) NVIDIA dlloader X Driver  510.60.02  Wed Mar 16 11:07:20 UTC 2022
[   105.899] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   105.899] (--) Using syscons driver with X support (version 2.0)
[   105.899] (--) using VT number 9

[   106.132] (II) Loading sub module "fb"
[   106.132] (II) LoadModule: "fb"
[   106.132] (II) Loading /usr/local/lib/xorg/modules/libfb.so
[   106.132] (II) Module fb: vendor="X.Org Foundation"
[   106.132]     compiled for 1.20.14, module version = 1.0.0
[   106.132]     ABI class: X.Org ANSI C Emulation, version 0.4
[   106.132] (II) Loading sub module "wfb"
[   106.132] (II) LoadModule: "wfb"
[   106.132] (II) Loading /usr/local/lib/xorg/modules/libwfb.so
[   106.132] (II) Module wfb: vendor="X.Org Foundation"
[   106.132]     compiled for 1.20.14, module version = 1.0.0
[   106.132]     ABI class: X.Org ANSI C Emulation, version 0.4
[   106.132] (II) Loading sub module "ramdac"
[   106.132] (II) LoadModule: "ramdac"
[   106.132] (II) Module "ramdac" already built-in
[   106.132] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   106.132] (II) NVIDIA(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[   106.132] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[   106.132] (==) NVIDIA(0): RGB weight 888
[   106.132] (==) NVIDIA(0): Default visual is TrueColor
[   106.132] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   106.132] (**) NVIDIA(0): Enabling 2D acceleration
[   106.133] (II) Loading sub module "glxserver_nvidia"
[   106.133] (II) LoadModule: "glxserver_nvidia"
[   106.133] (II) Loading /usr/local/lib/xorg/modules/extensions/libglxserver_nvidia.so
[   106.135] (II) Module glxserver_nvidia: vendor="NVIDIA Corporation"
[   106.135]     compiled for 1.6.99.901, module version = 1.0.0
[   106.135]     Module class: X.Org Server Extension
[   106.135] (II) NVIDIA GLX Module  510.60.02  Wed Mar 16 11:05:18 UTC 2022
[   106.135] (II) NVIDIA: The X server supports PRIME Render Offload.
[   106.957] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:83:0:0
[   106.957] (--) NVIDIA(0):     DFP-0
[   106.957] (--) NVIDIA(0):     DFP-1
[   106.957] (--) NVIDIA(0):     DFP-2
[   106.957] (--) NVIDIA(0):     DFP-3 (boot)
[   106.957] (--) NVIDIA(0):     DFP-4
[   106.957] (--) NVIDIA(0):     DFP-5
[   106.957] (--) NVIDIA(0):     DFP-6
[   106.957] (--) NVIDIA(0):     DFP-7 (boot)
[   106.957] (II) NVIDIA(0): NVIDIA GPU Quadro P620 (GP107GL-A) at PCI:83:0:0 (GPU-0)
[   106.957] (--) NVIDIA(0): Memory: 2097152 kBytes
[   106.957] (--) NVIDIA(0): VideoBIOS: 86.07.90.00.a7
[   106.957] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   106.957] (--) NVIDIA(GPU-0): DFP-0: disconnected
[   106.957] (--) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[   106.957] (--) NVIDIA(GPU-0): DFP-0: 1440.0 MHz maximum pixel clock
[   106.957] (--) NVIDIA(GPU-0): 
[   106.958] (--) NVIDIA(GPU-0): DFP-1: disconnected
[   106.958] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[   106.958] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[   106.958] (--) NVIDIA(GPU-0): 
[   106.958] (--) NVIDIA(GPU-0): DFP-2: disconnected
[   106.958] (--) NVIDIA(GPU-0): DFP-2: Internal DisplayPort
[   106.958] (--) NVIDIA(GPU-0): DFP-2: 1440.0 MHz maximum pixel clock
[   106.958] (--) NVIDIA(GPU-0): 
[   107.050] (--) NVIDIA(GPU-0): SAMSUNG (DFP-3): connected
[   107.050] (--) NVIDIA(GPU-0): SAMSUNG (DFP-3): Internal TMDS
[   107.050] (--) NVIDIA(GPU-0): SAMSUNG (DFP-3): 300.0 MHz maximum pixel clock
[   107.050] (--) NVIDIA(GPU-0): 
[   107.050] (--) NVIDIA(GPU-0): DFP-4: disconnected
[   107.050] (--) NVIDIA(GPU-0): DFP-4: Internal DisplayPort
[   107.050] (--) NVIDIA(GPU-0): DFP-4: 1440.0 MHz maximum pixel clock
[   107.050] (--) NVIDIA(GPU-0): 
[   107.050] (--) NVIDIA(GPU-0): DFP-5: disconnected
[   107.050] (--) NVIDIA(GPU-0): DFP-5: Internal TMDS
[   107.050] (--) NVIDIA(GPU-0): DFP-5: 165.0 MHz maximum pixel clock
[   107.050] (--) NVIDIA(GPU-0): 
[   107.050] (--) NVIDIA(GPU-0): DFP-6: disconnected
[   107.050] (--) NVIDIA(GPU-0): DFP-6: Internal DisplayPort
[   107.050] (--) NVIDIA(GPU-0): DFP-6: 1440.0 MHz maximum pixel clock
[   107.050] (--) NVIDIA(GPU-0): 
[   107.144] (--) NVIDIA(GPU-0): SAMSUNG (DFP-7): connected
[   107.144] (--) NVIDIA(GPU-0): SAMSUNG (DFP-7): Internal TMDS
[   107.144] (--) NVIDIA(GPU-0): SAMSUNG (DFP-7): 165.0 MHz maximum pixel clock
[   107.144] (--) NVIDIA(GPU-0): 
[   107.153] (==) NVIDIA(0): 
[   107.153] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[   107.153] (==) NVIDIA(0):     will be used as the requested mode.
[   107.153] (==) NVIDIA(0): 
[   107.153] (II) NVIDIA(0): Validated MetaModes:
[   107.153] (II) NVIDIA(0):     "DFP-3:nvidia-auto-select,DFP-7:nvidia-auto-select"
[   107.153] (II) NVIDIA(0): Virtual screen size determined to be 5760 x 2160
[   107.160] (--) NVIDIA(0): DPI set to (80, 80); computed from "UseEdidDpi" X config
[   107.160] (--) NVIDIA(0):     option
[   107.161] (II) NVIDIA: Reserving 24576.00 MB of virtual memory for indirect memory
[   107.161] (II) NVIDIA:     access.
[   107.195] (II) NVIDIA(0): Setting mode "DFP-3:nvidia-auto-select,DFP-7:nvidia-auto-select"
[   107.243] (==) NVIDIA(0): Disabling shared memory pixmaps
[   107.243] (==) NVIDIA(0): Backing store enabled
[   107.243] (==) NVIDIA(0): Silken mouse enabled
[   107.243] (==) NVIDIA(0): DPMS enabled
[   107.243] (II) Loading sub module "dri2"
[   107.243] (II) LoadModule: "dri2"
[   107.243] (II) Module "dri2" already built-in
[   107.243] (II) NVIDIA(0): [DRI2] Setup complete
[   107.243] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[   107.243] (II) Initializing extension Generic Event Extension
[   107.243] (II) Initializing extension SHAPE
[   107.243] (II) Initializing extension MIT-SHM
[   107.244] (II) Initializing extension XInputExtension
[   107.244] (II) Initializing extension XTEST
[   107.244] (II) Initializing extension BIG-REQUESTS
[   107.244] (II) Initializing extension SYNC
[   107.244] (II) Initializing extension XKEYBOARD
[   107.244] (II) Initializing extension XC-MISC
[   107.245] (II) Initializing extension SECURITY
[   107.245] (II) Initializing extension XFIXES
[   107.245] (II) Initializing extension RENDER
[   107.245] (II) Initializing extension RANDR
[   107.245] (II) Initializing extension COMPOSITE
[   107.246] (II) Initializing extension DAMAGE
[   107.246] (II) Initializing extension MIT-SCREEN-SAVER
[   107.246] (II) Initializing extension DOUBLE-BUFFER
[   107.246] (II) Initializing extension RECORD
[   107.246] (II) Initializing extension DPMS
[   107.246] (II) Initializing extension Present
[   107.247] (II) Initializing extension DRI3
[   107.247] (II) Initializing extension X-Resource
[   107.247] (II) Initializing extension XVideo
[   107.247] (II) Initializing extension XVideo-MotionCompensation
[   107.247] (II) Initializing extension GLX
[   107.247] (II) Initializing extension GLX
[   107.247] (II) Indirect GLX disabled.
[   107.247] (II) GLX: Another vendor is already registered for screen 0
[   107.247] (II) Initializing extension XFree86-VidModeExtension
[   107.247] (II) Initializing extension XFree86-DGA
[   107.248] (II) Initializing extension XFree86-DRI
[   107.248] (II) Initializing extension DRI2
[   107.248] (II) Initializing extension NV-GLX
[   107.248] (II) Initializing extension NV-CONTROL
[   107.248] (II) Initializing extension XINERAMA
[   107.320] (II) config/udev: Adding input device System mouse (/dev/input/event0)
[   107.320] (II) No input driver specified, ignoring this device.
[   107.320] (II) This device may have been added with another device file.
[   107.320] (II) config/udev: Adding input device System keyboard multiplexer (/dev/input/event1)
[   107.320] (**) System keyboard multiplexer: Applying InputClass "Evdev keyboard"
[   107.320] (II) No input driver specified, ignoring this device.
[   107.320] (II) This device may have been added with another device file.
[   107.320] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event2)
[   107.321] (**) Logitech USB Receiver: Applying InputClass "Evdev keyboard"
[   107.321] (II) No input driver specified, ignoring this device.
[   107.321] (II) This device may have been added with another device file.
[   107.321] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event3)
[   107.321] (**) Logitech USB Receiver: Applying InputClass "Evdev keyboard"
[   107.321] (II) No input driver specified, ignoring this device.
[   107.321] (II) This device may have been added with another device file.
[   107.321] (II) config/udev: Adding input device vendor 0x09da USB Keyboard (/dev/input/event4)
[   107.321] (**) vendor 0x09da USB Keyboard: Applying InputClass "Evdev keyboard"
[   107.321] (II) No input driver specified, ignoring this device.
[   107.321] (II) This device may have been added with another device file.
[   107.321] (II) config/udev: Adding input device vendor 0x0557 product 0x2419 (/dev/input/event5)
[   107.321] (**) vendor 0x0557 product 0x2419: Applying InputClass "Evdev keyboard"
[   107.321] (II) No input driver specified, ignoring this device.
[   107.321] (II) This device may have been added with another device file.
[   107.321] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event6)
[   107.321] (II) No input driver specified, ignoring this device.
[   107.321] (II) This device may have been added with another device file.
[   107.321] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event7)
[   107.321] (II) No input driver specified, ignoring this device.
[   107.321] (II) This device may have been added with another device file.
[   107.321] (II) config/udev: Adding input device vendor 0x0557 product 0x2419 (/dev/input/event8)
[   107.321] (II) No input driver specified, ignoring this device.
[   107.321] (II) This device may have been added with another device file.
[   124.965] (II) NVIDIA(GPU-0): Deleting GPU-0
[   125.199] (II) Server terminated successfully (0). Closing log file.

For each of /dev/input/eventX I get
No input driver specified, ignoring this device. This device may have been added with another device file.

What has changed? How do I get my mouse and keyboard back (in X)? (X not being much good without them.)
 
They are. That might have been pertinent at the time.

I tried deleting the package and building again with synth with the same results.

Then deleted and installed xorg from the quarterly repository, and it worked! So deleted it again, and built again with synth. It worked, it works.

I will mark this thread as solved, although really, it is not solved, I just bashed around till it worked. Much as though I like synth, I have come across a few cases when upgrading some, or many packages, does not seem to have everything done right.
 
Top