No disks found on ASUS P5N-D, nForce 750i.

I have an ASUS P5N-D motherboard with an Nvidia nForce 750i chipset, and a Seagate 500GB SATA 3.0Gb/s hard drive. When I try to install FreeBSD 7.0 i386 from the bootonly CD, I get a "No disks found!" error when it gets to the partitioning section.

Can anyone help?
the same

Hi ,i've got the same problem with this motherboard.
My HDD is a maxtor , 500 go sata2. precisely like you.
I installed it in safe mode but i can only use it in safe mode ,it can't mount the root partition in normal mode...
i think its a chipset problem.
As usual: try other releases. If you tried 7.0, it is now time to try 7.1.
If that doesn't work, try 6.4.
I'm having same problem with Asus P5KPL-AM/PS motherboard. I've already tried 6.3 and 7.1 with no luck. Anyone has solution? Or is this motherboard just not compatible with FreeBSD? Left support email to Asus, but haven't got an answer.

I wouldn't, only change to ata is module support.

To rule out BIOS, check for an 'enhanced' mode and set it if there, or unset the reverse 'legacy' mode. Also check jumpers on disk.
Though, there are issues with nvidia chipsets, better check the basics before doing anything drastic and/or reporting.

Found one report, but reporter never followed up, so unsolved. You might want to re-open or make a new report already giving the information vwe@ asked for.
Not a valid link.


09/11/2008 01:35AM Directory 200809
10/24/2008 04:29AM Directory 200810
11/17/2008 05:09AM Directory 200811
12/06/2008 06:22PM Directory 200812
07/07/2005 12:00AM 766 README.TXT
10/24/2006 12:00AM Directory bsdinstaller

There are no STABLE's, just 6.4/7.1-PRERELEASE and 8.0-CURRENT.

I've tried 7.1-CURRENT. It sees the SATA HD and lets me install during safemode only. But once finished and rebooted in normal mode it stops during:
hptrr: no controller detected

I've read this has to do with raid, but my Asus doesn't have raid feature.

Asus P5KPL-AM/PS, Northbridge: G31 Southbridge: ICH7

itchibahn said:
Not a valid link.
Maybe it will not help, but it is.
Cache or something?
$ ftp -a
ftp> ls
229 Entering Extended Passive Mode (|||22842|)
150 Here comes the directory listing.
drwxrwxr-x    2 110      1002         3072 Sep 11 00:28 200809
drwxrwxr-x    2 110      1002         1536 Oct 24 03:48 200810
drwxrwxr-x    2 110      1002         1536 Nov 17 09:06 200811
drwxrwxr-x    2 110      1002         1536 Dec 06 18:46 200812
[color=green]drwxr-xr-x    2 110      1002         2048 Mar 01 01:09 200902[/color]
-rw-rw-r--    1 110      1002          766 Jul 07  2005 README.TXT
drwxrwxr-x    2 110      1002          512 Nov 03  2007 bsdinstaller
226 Directory send OK.
ftp> bye
221 Goodbye.
Try fetching directly $ fetch [url][/url]