• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

No "check_nrpe" on my Nagios server

jbruyet

Member


Messages: 41

#1
Hey all, I just installed Nagios Core v3.3.1 on my 9.1 server. I entered the configurations for my switches and all is working fine. Then I did some configurations for some workstations and no joy. I did some checking and discovered that under /usr/local/libexec/nagios I don't have the "check_nrpe" command. I thought I needed to manually install (from the ports) the Nagios Plugins but when I tried the install I received a message stating that the plugins are already installed. I Googled the problem but all I'm finding is how to monitor a FreeBSD server from a Nagios server. So, does anyone know how to get NRPE monitoring/the check_nrpe command configured on Nagios running on FreeBSD?

Thanks,

Joe B
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 5,492
Messages: 25,656

#2
Oddly enough the port's name doesn't include Nagios: net-mgmt/nrpe2
 

marypoppins

New Member


Messages: 10

#4
Dear All,

I have a same issue on freebsd11. I'm using icinga2. If I try to install nrpe3 package, it wants to remove icinga2. I would like to ask if I try to install net-mgmt/nrpe3 port is there any chance that it would work together with icinga2?
Or where can I get the check_nrpe?

Thank you
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 5,492
Messages: 25,656

#5
If I try to install nrpe3 package, it wants to remove icinga2.
With a quick glance I can't really find a reason why it would this. Can you post the whole output of pkg install nrpe3? Just say no to the actual install, I'm only interested in the list of things it wants to install/remove/replace. I'm suspecting it's some dependency that's causing it.
 

marypoppins

New Member


Messages: 10

#6
Installed packages to be REMOVED:
icinga2-2.8.1
monitoring-plugins-2.2_3
New packages to be INSTALLED:
nagios-plugins: 2.2.1_5,1

I realized this machine is a virtual machine, so i made a snapshot and tried to install the ports. When I run the make, it was checked to use the nagios-plugins default, so I change it to use the monitoring-plugins which comes with icinga2.
I think the nrpe3 package based only on the nagios-plugins and does not want to use the monitoring-plugins.
Thank you for your answer!