No BSD For Me?

I've tried to get information from all over the net on this.....

I have a second computer at home for playing around. My kids use it all the time, and FWIW, don't seem to mind which OS is on it.

I have SuSE (11.0) on the main HDD and recently installed a second HDD for playing with other Linuxes. About a week ago I got tired of Fedora 9, and wanted to try a BSD instead. You know where this is going.....

I downloaded DesktopBSD 1.6 to CD's. Never even got it installed. "Cannot dump. No dump device defined". No matter what install options I choose, same result.

Off to Google I go. The BIOS is the latest and greatest Gigabyte has. Disabled Legacy USB. Unplugged all USB apparata. The keyboard and mouse are not USB.

So, I downloaded PC-BSD 7.0.2. Same result. All the ISO's checksum exactly. Used different "parent" computers for the downloads. Same result. Hmmmmmm.

So then it's FreeBSD to 3 CD's. Same result - "Cannot dump. No dump device defined.".

Tomorrow, I'm going to bring the HDD to work with me and try to install it here. Then take the HDD back to the computer and just plug it in. Any experience here? Will it (can it) work? I'll let you know.

Does anybody have any experience with OpenBSD? Are the results there likely to be any different, or is this an issue across the BSD spectrum?

What is it with all this dumping anyhow? It isn't only my problem. Do the "Brains of the Outfits" know about this? I don't want to claim on anyone's pride and joy, but it doesn't appear that this BSD thing is ready for prime time.

That said, I'm a stubborn fart and will keep trying. I want to see how this OS works.

Home Built Computer
Gigabyte GA-MA69G-S3H
2Gb Corsair
Athlon 5200+
2 ea. - Western Digital 250 Gb SATA
HP DVD740ri
Hard Wired Ethernet Connection
"Cannot dump. No dump device defined" is not the cause of your problems -- it's a follow-up error which gets raised when the kernel panics but has no media to dump state to. What output do you get before that?
Do check for hardware problems namely RAM. You can use memtest86+ to check RAM for instances.

You take the HDD and use another PC with the same architecture and install there. However when you plug it back in it will probably complain about the root partition and so on, which you can fix with fixit CD.

Passed Memtest86+ with 0 errors. ;) (I knew it would) :e

Last lines
panic ohci_add_done_0x77ef1ce0 not found
runtime 1 s
Cannot Dump. No Dump Device Defined.

I wish I knew what to do. I want to be able to run BSD on my computer. I'm going to try installing it on my work computer and then bringing the functional HDD home and plugging it in here. We'll see - I'll let you guys know.

I've tried:

DesktopBSD 1.6
PC-BSD 7.0.2
FreeBSD 7.1

The thing is that I get the same result with each flavor I try to install. The installation halts at the same place, and with the same message.

The computer, while it's no hot rod, is pretty new and very reliable. While I've never had Windows of any type on it, I've run several distros of Linux with no issues at all.

Thank you for any ideas you may have. If you Google "Cannot dump" "BSD", there are a lot of people who have this same issue, but there aren't any solutions.

I'm looking for ideas.
Well, it's some kind of compatibility problem with the OHCI module (which is part of the USB subsystem). Some fixes (for boards other than your own which exhibit the same behavior) include updating the BIOS or building a kernel with OHCI compiled out. Without OHCI you might not have USB support.

One thing you might try is to grab a snapshot from CURRENT from after the new USB stack was made default in GENERIC and see if that works (since the old OHCI code was rewritten, IIRC). The only other options that I can think of are building a custom kernel without OHCI (which is kind of hard without another FreeBSD system) or replacing the motherboard (which isn't really a feasible option).

EDIT: Actually, I don't remember if USB2 was actually made default in GENERIC, but it was planned to happen around last week. The problem is, the latest snapshot (that I could find) was from last month, so it definitely doesn't have USB2 compiled in :(

You might have better luck with OpenBSD or NetBSD (since the BSDs, unlike Linux, don't all use the same kernel under the hood).
Try to disable support for USB legacy devices in BIOS.
I do use OpenBSD and the system is quite different than FreeBSD that you might not experience the same problems. NetBSD should have similar USB stuck as OpenBSD or at least be less different from OpenBSD than from FreeBSD. I believe that USB stuck is completely rewritten in DragonFly which is a fork of FreeBSD so you could try that one as well.
Don't give up. I don't know what your problem is, but I have never had a problem at least getting FBSD installed. The biggest problem I have had is it complaining about disk geometry. I just ignore it (maybe I'm lucky?) and then after the install go into partition magic which complains and then it says it has fixed the parition table. Risky when you don't know exactly what you are doing; maybe someday I'll sit down and figure that out. But, just don't give up. I like freebsd. My only real complaint is lack of a flash player. Wine has really made some improvements.
No Luck

I installed a fully functional copy of FreeBSD on the HDD at work yesterday.

Brought it home, plugged it in and got.......

Nothing. No boot screen, no nothing. Just blackness. Plugged the SuSE drive back in and got....... SuSE!

:( <Sound of hair slowly being pulled out> :(

I'm downloading OpenBSD even as we speak.

We'll see.
You need to boot the install DVD and go the Configure -> Fdisk / Label and set the bootable flag and make sure you have the Boot Manager installed.

Fixit CD is livefs CD; nowadays the DVD can also be used to fix issues in an install.

Masterbuilder said:
I installed a fully functional copy of FreeBSD on the HDD at work yesterday.

Brought it home, plugged it in and got.......

Nothing. No boot screen, no nothing. Just blackness. Plugged the SuSE drive back in and got....... SuSE!

:( <Sound of hair slowly being pulled out> :(

I'm downloading OpenBSD even as we speak.

We'll see.

I have been wanting to try openbsd; at least on my server.

Time is a problem.
dont pull your hair out that sux the thing you need to do is download the iso image of the others not the live cd it sucks the isp's need to improve on it.
Install Media

I've been using ISO's for all my installs. I checksum the images after downloading. I don't think the issue is the media.

I ordered the CD set directly from OpenBSD. That should put that issue to rest.

I'll keep you posted.