No boot after succesful install

Trying to install freeBSD on my Thinkpad W520 i7-2820. Boot from CD to start installer works fine, and I have no trouble with installing freeBSD on a USB Flash attached to the PC. After installation, then I restart and tries to boot from USB Flash, but nothing happens.

I have of course set the BIOS to boot from USB Flash, but the boot seems to just loop without any try to execute the freeBSD from USB Flash.

Have also tried to install directly to one of the SSD disk on the Thinkpad, but the same happens, the boot process just returns to the boot device menu withing less than a secod, nothing is displayed on the screen, no error message, just return to list of boot devices

Have tried to turn off as much as possible devices in the BIOS, but no luck.

Where do I start to resolve this ? The installation program seems to run Unix and have no trouble at all to execute, so it should be possible to run freeBSD on that machine ? The installation process is just fine and it sees all my disks and creating all partitions seems to go well.

Can you reset the BIOS to Default, or factory setting and reboot into the SSD without the USB? Will it boot to any internal drive[s}? Make a record of BIOS settings you want to keep before reset!
Try setting the master boot record. On the live cd, open a shell and type
boot0cfg -B device
where device is your drive, ada0 for the first SATA HDD and da0 for the first usb drive