No BMC response once the NIC detected in Freebsd

k.jacker

Well-Known Member

Thanks: 231
Messages: 446

#2
Hei,
I don't know the your Dell's IPMI but, do you have configured LAN (inside FreeBSD) and the IMPI to have the same IP-adress on the shared NIC?
They should be different.
 
OP
OP
F

freebuser

Member

Thanks: 5
Messages: 97

#3
Hi,
Yes, it has been set up with a different IP.
After the above link and this https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=196944 I ended up with merging if_bge.c from 9.1 and STABLE 11 to compile a new kernel and it works without a problem now. Not sure what exactly missing from 9.1 to 11 (or even 9.2 from the above link).

I had a couple of errors in compiling but after removing those references it compiled without a problem (AFAIK).

Cheers.
 

k.jacker

Well-Known Member

Thanks: 231
Messages: 446

#4
So it really has been broken since 9.x.
I read through your link and think it's weird that it works with PXE enabled in the BIOS.
Can't think of anything how PXE would affect the bge-driver in FreeBSD to make it work, but I'm not a kernel developer so that is a little above my knowledge ;-)
Haven't really ever thought about how IMPI and networking works on a shared NIC but there must be some kind of routing that catches the traffic to IPMI's IP-adress before the OS gets it..
Maybe it's just that the interface is initialized by the BIOS allready and the IPMI access is preserved that way.

Nice you got it working!
 
OP
OP
F

freebuser

Member

Thanks: 5
Messages: 97

#5
this is the link for the diff between current STABLE 11 and my working if_bge.c files.

If someone could let me know what exactly is the change I need to implement in the original STABLE 11 it would be really helpful to get rid of any unwanted code in the modified (working) file.

Thanks

https://www.diffchecker.com/2f8X0hor
 
Top