ngircd: Password protecting channels

time4e

Member


Messages: 50

Hi,

So far I've found ngircd to be the easiest IRC servers in the ports tree to get up and running. I'm having some trouble creating a password protected private channel. I have a feeling that I'm not using the key = line correctly.

ngircd.conf example
Code:
[Channel]
name = #mychannel
mode = +k (have tried with and without)
Key = mypassword

After restarting the service I'm able to join the channel without the password, I'm sure its something simple I'm missing and any help would be greatly appreciated.

Thanks,
-Tim
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,323
Messages: 38,841

time4e said:
Code:
[Channel]
name = #mychannel
mode = +k (have tried with and without)
Key = mypassword
I'm not sure if +k would work, have you tried tnk?
 
OP
time4e

time4e

Member


Messages: 50

SirDice said:
time4e said:
Code:
[Channel]
name = #mychannel
mode = +k (have tried with and without)
Key = mypassword
I'm not sure if +k would work, have you tried tnk?

@SirDice,

I have tried setting the following in ngircd.conf
Code:
[Channel]
name = #mychannel
mode = +tnk
Key = mypassword

After restarting the ngircd service I'm still able to join the channel without a password. Any other ideas?

Thanks,
-TIm
 
Last edited by a moderator:

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,323
Messages: 38,841

Yes, remove the plus sign. It's not mentioned anywhere in the documentation.
 
OP
time4e

time4e

Member


Messages: 50

SirDice said:
Yes, remove the plus sign. It's not mentioned anywhere in the documentation.

@SirDice,

The configuration uses an example with + anyway I have tried without the + and have also tried +i (also without +) and I'm still able to join the channel without the password :( Could you recommend another IRC server that could support this feature more easily?

Thanks,
-Tim
 
Last edited by a moderator:
OP
time4e

time4e

Member


Messages: 50

Okay as SirDice mentioned I was not reading the documentation properly I was using "mode" when I should have been using "modes" and the + is not required. All is working now.
 
Top