nfe0 (NIC) pings lo0, but nothing else, Guidance Requested

SirWinstonoboogie

New Member


Messages: 14

Hello All,

1st, let me say that I'm quite new to this OS (I have Cisco training though), but I've done some searching around on this, let me try to put across my networking issue:

This is a new install (7.1) - I checked the Hardware Notes for my Mobo, prior to starting.
Its a Nvidia 'MCP51' controller, and it is listed for the nfe driver -

FreeBSD apparently recognizes it, so I'll get to the symptom.

-Ping Loopback > good
-Ping static 192.168.10.100 > Good

But after a Boot, and all the scrolling stuff appears, I get this hex error:

'nfe0 tx V2 error 0X6004'

I'm lost now, don't know where to start... but:

looked at ifconfig (this after searching around - the bolded partial, below apparently indicates a problem)
a partial listing below:

nfe0: flags=884(UP BROADCAST MULITCAST...)3metric 0 mtu 1500

options=8
. MAC
. inet6 XXXXXXXXX ....
. inet 0.0.0.0 netmask (hex)ff000000 bcast 255 255 255 255
. autoselect 100base /half duplex
status Active
*also, a line here-
'network_interfaces="lo0_nfe0'

Finally, there's another Nividia driver listed in the hardware notes, for the NForce4, which jives with the Mobo -
Is this a possibility- to change the driver?(I wouldn't know where to start, except the handbook)

Thanks in advance, I'll hang up an listen.

Oh, 1 last thing - the NIC is Gigabit capable, but I saw someplace (netstat or ifconfig, IIRC) which indicates 100 mbs @ half duplex. My network is not Gig. capable, but I am expecting AutoNegotiation.
 

trev

Aspiring Daemon

Reaction score: 155
Messages: 767

There's good news and bad news :)

The good news: this does not happen if you use a 1Gbps connection.

The bad news: you night need to buy a gigabit switch.

I'd file a pr as the maintainer is quick to respond to these sorts of issues.
 
OP
OP
S

SirWinstonoboogie

New Member


Messages: 14

Well, Googling on

nfe0 tx V2 error 0X6004

kinda obliquely references Gig speed, as well as the fact that initially, the NIC goes to 100 half.

Update - I went to the Cisco SoHo gateway and set the corresponding interface to match: 100 Half duplex.

Result: Same response - 'nfe0 tx V2 error 0X6004'

.. Can't find a reference to the error.
 
OP
OP
S

SirWinstonoboogie

New Member


Messages: 14

Just a FYI to all -


-Finally narrowed it down. Turns out to be a rpoblem with the Cisco SoHo Router/Gateway.

I bypassed the Gateway completely, plugged direct into the ISP, reconfigured using SysInstall, and all's well.
Now at least I can get to the Ports and Packages aspects.
 

Mel_Flynn

Well-Known Member

Reaction score: 81
Messages: 379

SirWinstonoboogie said:
looked at ifconfig (this after searching around - the bolded partial, below apparently indicates a problem)
a partial listing below:

nfe0: flags=884(UP BROADCAST MULITCAST...)3metric 0 mtu 1500

options=8
. MAC
. inet6 XXXXXXXXX ....
. inet 0.0.0.0 netmask (hex)ff000000 bcast 255 255 255 255
. autoselect 100base /half duplex
status Active
*also, a line here-
'network_interfaces="lo0_nfe0'
SirWinstonoboogie said:
Just a FYI to all -


-Finally narrowed it down. Turns out to be a rpoblem with the Cisco SoHo Router/Gateway.

I bypassed the Gateway completely, plugged direct into the ISP, reconfigured using SysInstall, and all's well.
Now at least I can get to the Ports and Packages aspects.
I think that's not your problem. As indicated in purple, your interface has the 0.0.0.0 IP address, which indicates DHCP is used and the dhclient is unable to contact a DHCP server.
If the DHCP server is supposed to be enabled on the SoHo router, you can bring the interface down, then run dhclient -d nfe0 and try to determine what's not going right from there.
 
OP
OP
S

SirWinstonoboogie

New Member


Messages: 14

Thanks for that... Rereading my post, you are correct. I may have posted a wrong output.. things were going insane, as I edited so much in ifconfig.

Today, I finally tried a hunch based on 'simple is better'.
Just changed the Cisco interface:
speed 100
duplex auto (Was @ 'duplex')..like forcing the other end to this.

Coming from the Windows world, these settings were pretty much irrevelant... things worked here for too long.

Now I guess, with a Unix based OS, matching the 'autoselect' on the other end of the wire is important. (best guess, I dunno).

Now up @ 100/Full Duplex, behind my cozy Gateway w/ all firewall bells&whistles.
 
Top