Xfce New to FreeBSD : xOrg does not start neither xFce4 DE

Hi,
New to FreeBSD ( but not to Linux since 1993 and UnixMan on Engineer School in 1984 ) then ok for script & all if necessary.

I decided to install FreeBSD for fun as I stopped Unix end of 1999 ( iRMX ) and I want to play again Unix to learn it again and to have fun ...
xOrg fails to start...
Not a problem due to Hardware as this PC was running RedHat this Ootpa 8.6 Gnome on xOrg and I installed NomadBSD successfully except little PB with efi ( I need to choose manually the efi boot file )


But as said I want to have fun with FreeBSD and I need for help...


INSTALLATION OF FreeBSD
It is so simple to install ( Slackware-like),
I only don't known how to encrypt Luks the partitions ( created manually ), If you can also me to encrypt the 2 partitions It would be nice...
PartitionsTypeSizeMountpointEncryptions
ada0p1efi500MB/boot/efi
ada0p2freebsd-ufs220GB/to be encrypted help welcomed
ada0p3freebsd-swap18GBswapto be encrypted help welcomed


INSTALLATION OF xFce4 DE ON FreeBSD
What did I made wrong, please ?
pkg update; reboot; pkg install -y nano; pkg install -y xorg; pkg install -y xfce; pkg install -y slim; pkg install -y slim-themes; nano /etc/rc.conf dbus_enable="YES" hald_enable="YES" slim_enable="YES" nano /home/user1/.xinitrc startxfce4 nano /home/user2/.xinitrc exec startxfce4 pkg update; reboot;


WHAT FAILED WITH xFce4 DE
Slim does not start automatically...
startx gives :

Fatal server error (EE) (EE) Cannot run in framebuffer mode. Please secify busIDs for all framebuffer devices .... (EE) Server terminated with error (1). Closing log file. xinit: giving up xinit: unable to connect X server . Connection refused xinit: server error



I TRYIED THIS
Xorg -configure X -configure /root/xorg.conf.new
Then
xrandr gives
Can't open display


VERSION OF FreeBSD

cat /etc/os-relase
gives
NAME=FreeBSD VERSION=13.0-RELEASE VERSION_ID=13.0 ID=freebsd ANSI_COLOR="0;31" PRETTY_NAME="FreeBSD 13.0-RELEASE" CPE_NAME=cpe:/o:freebsd:freebsd:13.0 HOME_URL=...

( I could not ask for grep with bash ? " cat /etc/os-relase | grep NAME " failed , pkg info bash gives Name : bash and Version : 5.1.16 )
 
This whole step can be avoided on only Intel CPU graphics:
Setting the Video Driver in a File
Just install the correct DRM video driver and this is not needed.
Now if you have a computer with Intel CPU and NVidia graphics you might need to set the video driver.
 
There is no lspci on freebsd but you can report what pciconf -lv |grep -B 4 VGA returns. Most likely you will need
pkg install -y drm-kmod unless you have an nvidia device.

pciconf -lv |grep -B 4 VGA returns 100 lines...
I tried to add | less idem..
But there is :
vgapci00pci0:0:2:0: class=0x030000 rev=0x06 hdr=0x00 vendor=0x8086 device=0x1912 subvendor=0x103c subdevice=0x8056 vendor = 'Intel Corporation' device = 'HD Graphics 530' class = diplay subclass = VGA

I've installed neofetch ( as there is no dmidecode and as xrandr does not work )
CPU: Intel i7-6700 (8) # 3.408GHZ
GPU: HD Graphics 530

For info :
The Display is connected at DP-1 ( Display-Port 01)
and the mouse works...
 
Also please use FreeBSD-13.1. There is no sense starting with an old version.

FreeBSD version 13.1 installed now

cat /etc/os-relase.
gives
.NAME=FreeBSD VERSION=13.1-RELEASE VERSION_ID=13.1 ID=freebsd ANSI_COLOR="0;31" PRETTY_NAME="FreeBSD 13.1-RELEASE" CPE_NAME=cpe:/o:freebsd:freebsd:13.1 HOME_URL=...

But nothing changed ...
 
All you need is here:

Sorry that is not the case :

# pkg install xorg; done
# pw groupmod video -m user || pw groupmod wheel -m user done during installation ( wheel + operator + video )
% startx Failed
 
All you need is here:

That is correct.

However, it seems to be a recurring theme, that new users install Freebsd, xorg and a few other packages, and then wonder why it does not all start up like magic.

Does the handbook not have enough emphasis on video cards?
 
Thanks but how ?
OK you established that Intel Video in use. That means i915drm.
pkg search drm
Code:
drm-fbsd13-kmod-5.4.144.g20220223 DRM modules for the linuxkpi-based KMS components
GOTO
pkg install drm-fbsd13-kmod
Pay VERY close attention to the package message. You need to put an entry in /etc/rc.conf for Intel video.
 
% startx Failed
No video driver expect failure..

Plus it don't sound like you followed the handbook correctly.
For Xfce4 there is a section. You need a session. Did you do that?

There is a cheater script installed with Xfce4.
Try this instead after you get your video right.
startxfce4
 
Hi everybody,

First thanks a lot for all your replies...

I found antother solution : DragonFly BSD :
  1. Still on BSD
  2. Very easy partitions encryption
  3. Mate Desktop installed in 5 minutes : I prefer Cinnamon but I like Mate ( 'compiz' ) much better than xFCE4
For info :

pkg update; pkg upgrade; pkg install -y nano; pkg install -y xorg; pkg install -y mate; pkg install -y slim; pkg install -y slim-themes;

Then
nano /etc/rc.conf
I add:
dbus_enable="YES" hald_enable="YES" slim_enable="YES"

Then
nano /home/unixman/.xinitrc
I add:
exec mate-session

Then
reboot;

Here is the results !
Hello Geezer : It it does all start up like magic.... :p Keep It Stupidly Simple ( OK this is for Linux but it worked also for DragonFly BSD )
Thanks again to everybody ! I've really appreciated your help and fast replies...
1656251065982.png
 
Top