ZFS New raidz2 auto unmounting without error

I set up this array yesterday on FreeBSD 10.2 and exported it with NFS and net/samba43, all started working just fine, but after a few hours the array is unmounting itself without error in logs or any other indication of problem when I remount it

theshitt  55.5G  2.50T  55.5G  /mnt/theshitt

  pool: theshitt
state: ONLINE
  scan: resilvered 60K in 0h0m with 0 errors on Mon Feb  8 12:51:59 2016

   theshitt  ONLINE  0  0  0
    raidz2-0  ONLINE  0  0  0
    ada0  ONLINE  0  0  0
    ada1  ONLINE  0  0  0
    ada2  ONLINE  0  0  0
    diskid/DISK-9VS2XSSQ  ONLINE  0  0  0

errors: No known data errors

Hang on, I think the problem might be somewhere else, looks like the machine is rebooting by itself, that will explain why it was unmounted (because I didn't have zfs_enable="YES" in the config), it also explain why the console was logged out, and /var/log/messages shows the time the kernel restarts, I think this is a hardware problem :x
Last edited by a moderator:
It's a kernel crash, I tested hardware with memtest and mprime it's all good, the problem is that I can't give any information about the crash because the system reboots after 15 seconds and the crashes are not happening in identical intervals

I installed FreeBSD 10.2 AMD64 on a Core2 Duo machine:
Asus P5Q Mobo
Core 2 Duo E8400
12 GB of DDR2 RAM

I created the pool with default settings in 10.2

I also tried to delete FreeBSD 10.2 and installed 9.3 (and updated) - it still randomly crashes
I also tried to update the kernel of the 10.2 release - still crashes
htop says memory use of the system is 3 GB and I never saw it go above that. FreeBSD 9.3 can't use FreeBSD 10.2's version of ZFS so the kernel crashes not because of ZFS. There is nothing useful in the logs, no indication of crash.

What version of FreeBSD is a stable version that doesn't crash ?
Last edited by a moderator: