Solved network ip address created automatically on every boot

wolffnx

Well-Known Member

Reaction score: 73
Messages: 402

I dont know where this came from,but in every boot I see

Code:
inet 0.0.0.1 netmask 0xff000000 broadcast 0.255.255.255
in the 3 interfaces I have in my box, including Lo0

someone has the same "problem" ?

Code:
FreeBSD JShome 12.1-RELEASE-p7 FreeBSD 12.1-RELEASE-p7 GENERIC  amd64
my /etc/rc.conf

Code:
clear_tmp_enable="YES"
sendmail_enable="NONE"
hostname="JShome"
ifconfig_re0="DHCP"
ifconfig_re1="inet 10.1.80.1 netmask 255.255.255.248" #this ip is private so there is no need for change for post
sshd_enable="NO"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="NO"
savecore_enable="NO"
zfs_enable="YES"
keyrate="fast"


update_motd="NO"
dbus_enable="YES"
background_dhclient="YES"
defaultroute_delay="1"        # Time to wait for a default route on a DHCP interface.
defaultroute_carrier_delay="1"
moused_enable="NO"
virecover_enable="NO"
ip6addrctl_enable="NO"
rctl_enable="NO"
 

VladiBG

Aspiring Daemon

Reaction score: 338
Messages: 795

Post the output of
grep lo0 /etc/defaults/rc.conf

Do you have anything in /etc/rc.conf.d/ ?
 

Phishfry

Son of Beastie

Reaction score: 1,866
Messages: 4,903

You are using DHCP for interface re0 so it will not wait for an IP from your DHCP server. If you add "SYNCDHCP" does this change?
 
OP
wolffnx

wolffnx

Well-Known Member

Reaction score: 73
Messages: 402

You are using DHCP for interface re0 so it will not wait for an IP from your DHCP server. If you add "SYNCDHCP" does this change?
thanks for the advice, but not, instead dont work as expected (after my system boot in X) :

screen2.jpg


with only "DHCP" option en re0 I have the real ip plus the 0.0.0.1
 
OP
wolffnx

wolffnx

Well-Known Member

Reaction score: 73
Messages: 402

Post the output of
grep lo0 /etc/defaults/rc.conf
Code:
#ifconfig_lo0="inet 127.0.0.1"    # default loopback device configuration.
#ifconfig_lo0_alias0="inet 127.0.0.254 netmask 0xffffffff" # Sample alias entry.
I dont know why is comment, I never touch the defaults files


Do you have anything in /etc/rc.conf.d/ ?
No,nothing
 

usdmatt

Daemon

Reaction score: 551
Messages: 1,465

Those lines are supposed to be commented out. What scripts are in /usr/local/etc/rc.d.

I can think of anything obvious in FreeBSD that would cause this.

Something appears to be configuring ip address "1" on all your interfaces. It could be something not really designed for FreeBSD that is just running a badly formatted ifconfig command.
 
OP
wolffnx

wolffnx

Well-Known Member

Reaction score: 73
Messages: 402

Those lines are supposed to be commented out. What scripts are in /usr/local/etc/rc.d.

I can think of anything obvious in FreeBSD that would cause this.

Something appears to be configuring ip address "1" on all your interfaces. It could be something not really designed for FreeBSD that is just running a badly formatted ifconfig command.
you right, I modified some init scripts to make it less verbose , my error was :

Code:
  if check_startmsgs; then
                        for ifn in ${_ok}; do
                                /sbin/ifconfig ${ifn} 1> /dev/null
                        done
                fi
instead of

Code:
  if check_startmsgs; then
                        for ifn in ${_ok}; do
                                /sbin/ifconfig ${ifn} 1> /dev/null 2> /dev/null
                        done
                fi
according to vermaden guide FreeBSD Desktop – Part 1 – Simplified Boot
 
Top