NAS4Free on a Mac Pro 1,1

npaisnel

New Member

Reaction score: 1
Messages: 16

OK, hi to everyone..expecially those that are now reading this thinking ..aaarrgg another newbie who has not read the forum rules..and NAS4Free is not FreeBSD.....but calm yourselves gentlemen..I have read the Rules..let me explain...

Yes I have seen the thread about other derivatives , and here are my questions on the NAS4Free forum
Instal on 2006 mac Pro 1,1
NAS4Free on Mac Pro

But apart from my own random waffling no one has been able to shed any light on this for me which is why I have come here.


I am not after any major help here as yet...just maybe an answer to a simple question that no one on the NAS4Free forums has been able to answer.

I have flash upgraded the Boot Loader on the logic board to 2,1 so it does allow 64 bit OS, as per a 2007 Mac Pro 2,1.

As it is 'out of the box' NAS4Free does not control the Mac fans so it starts heating up , then random crashes start to happen. Installation also so far has been problematic and achieved by random trial and error.

Two Questions:
Has any one here successfully installed FreeBSD on a Mac Pro 1,1. ?

Is there any thing in the FreeBSD project that I can add in to the NAS4Free installation to allow Mac Pro fan control



To show I have at least a system running at the moment, here is a screen shot of where I have got to so far.

Many thanks

Neil



Screen Shot 2017-02-28 at 18.54.23.jpg
 

TN Tuxedo

New Member


Messages: 1

Neil,

I just completed an installation of FreeBSD on a MacPro 1,1 this week. However, I was never able to install 11.0 directly. I had to install 10.3, then upgrade.

The combination that worked for me is as follows:

- Installed from DVD using FreeBSD-10.3-RELEASE-amd64-dvd1.iso (NOTE: This is NOT the uEFI version. Since the MacPro1,1 has 32bit EFI and 64bit OS, the non-EFI version seems to work better.)
- During drive setup, I chose ZFS format with MBR (BIOS), 4g swap and single stripe.
- At the end of the installation, before rebooting, I went into the shell and executed the following terminal command:
Code:
gpart bootcode -b /boot/mbr ada0
- After rebooting, I performed an update...
Code:
freebsd-update fetch install
... followed by an upgrade.
Code:
freebsd-update -r 11.0-RELEASE upgrade
- Next, I installed the upgrade. This first execution patches the kernel.
Code:
freebsd-update install
- After a reboot, I installed the upgrade a second time with the same
Code:
freebsd-update install
command as before. This second execution patches everything else.

IMPORTANT NOTE: I found out after successfully installing 10.3-STABLE that the process of upgrading to 11.0 from a STABLE version is significantly more difficult than from a RELEASE version.

Good luck!
 
OP
OP
N

npaisnel

New Member

Reaction score: 1
Messages: 16

Looks like you tried a few different' ways' before you hit on the correct one !

I eventually found by re booting in to an original OSX instal of something like 10.5, that i had a hardware fault too....long story ..But in the end my machine was scrapped. I was given it with ehboard out the case..and only half the case...it had bee cut in half, to use the other half as a wall decoration for an advertising agency :( It had ben cut AFTER the mainboard had been removed, but I never got the full story..but I strongly began to suspect hardware failure.

But this is going to be very useful for others (or myself) in the future no doubt.

Did you ever come across the Mac Flash 32 -64 bit tool.


I also read something about the Apple 'Bless' command..something to do with the UEFI boot I believe..you need to 'bless ' the drive to make it bootable! typical naff Apple terminology !


http://forum.netkas.org/index.php/topic,1094.0.html

I'll leave you to read up and see if it is of any help to you


and good luck to you too with this
 
Top