nanobsd boot problem

j4ck

Active Member

Reaction score: 11
Messages: 113

Hi all
Thanks for helping me building a nanobsd image. I did build an image with no problems. But I have some problems in the second phase of running a device from an image. After copying the image on a flash memory, and after I set the system to boot up from flash memory, I just see a black screen and a blinking cursor! looks like the boot device (flash memory) is not recognized by the system. Here are my debugging information, if they are not enough, tell me please to send you necessary informations:
Dmesg output :
Code:
     da0 at umass-sim0 bus 0 scbus0 target 0 lun 0
     da0: <UFD 2.0 Silicon-Power8G PMAP> Removable Direct Access SCSI-4 device
     da0: 40.000MB/s transfers
     da0: 7388MB (15130624 512 byte sectors: 255H 63S/T 941C)
according to the last line, I change the NANO_SECTS to 63 and NANO_HEADS to 255. (in nanobsd.sh).
ls /dev output:
Code:
           da0s1           da0s1a     ad6s1b          da0s3           ad6s1d          da0s4
according to the first column, I set NANO_DRIVE to da0. (in nanobsd.sh)
and here are the contents of the flash memory :
ls /mnt
Code:
        .cshrc          boot            lib             rescue          usr
        .profile        cfg             libexec         root            var
        .snap           conf            media           sbin
        COPYRIGHT       dev             mnt             sys
        bin             etc             proc            tmp
Am I missing something? Could you please me please?
 
OP
OP
j4ck

j4ck

Active Member

Reaction score: 11
Messages: 113

Code:
If you have invalid mount options, reboot, and first try the following from the loader prompt :
	set vfs.root.mountfrom.options=rw
And then remove the invalid mount options from /etc/fstab.

Loader variables:
vfs.root.mountfrom=ufs:/dev/da0s1a
vfs.root.mountfrom.options=ro

Manual root filesystem specifications:
da0 at umass-sim0 bus 0 scbus0 target 0 lun 0
	<fstype>:<device> Mount <device> using filesystem <fstype>
da0 :	eg. Ufs:/dev/da0s1a
<UFD 2.0 Silicon-Power8G PMAP> Removable Direct Access SCSI-4 device
	Eg. Cd9660:/dev/acd0
da0: 40.000MB/s transfers	This is equivalent to:
mount –t cd9660 /dev/acd0/
da0: 7388MB (15130624 512 byte sector: 255H 63S/T 941C)
	?	List valid disk boot devices
	<empty line>	Abort manual input
mountroot >
List of valid devices :
Code:
mountroot>?
List of GEOM managed disk devices:
	da10s1a   da0s4   da0s3  da0s1   da0
I have to set the mount root manually :
Code:
mountroot>ufs:/dev/da0s1a
The system does not do this automatically. Fstab file is correct as you can see the “loader variables”.
What’s the problem ? I am so confused !!!
The point is that we don’t dace this problem on one our system !!!
 
Top