my usb wifi rt2870 not active

emir

New Member


Messages: 2

now rt2870 status - association, but not active. how make status to active?

roter dir-300 view rt2870 as wifi client, session not active

tryed dhcp and permanent ip

sorry for my english.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,108
Messages: 35,583

Please post the ifconfig output and any relevant configuration files.
 
OP
E

emir

New Member


Messages: 2

#ifconfig
Code:
plip0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> metric 0 mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
	options=3<RXCSUM,TXCSUM>
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2 
	inet6 ::1 prefixlen 128 
	inet 127.0.0.1 netmask 0xff000000 
	nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
run0: flags=8a43<UP,BROADCAST,RUNNING,ALLMULTI,SIMPLEX,MULTICAST> metric 0 mtu 2290
	ether 00:e0:4d:91:26:f4
	media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
	status: associated
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	ether 00:e0:4d:91:26:f4
	inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255
	media: IEEE 802.11 Wireless Ethernet OFDM/36Mbps mode 11g
	status: associated
	ssid CyberShoot channel 6 (2437 MHz 11g) bssid 00:24:01:18:8f:ad
	regdomain NONE country RU authmode WPA1+WPA2/802.11i privacy MIXED
	deftxkey 2 TKIP 2:128-bit txpower 30 bmiss 7 scanvalid 60 protmode CTS
	wme



/etc/rc.conf
Code:
ifconfig_run0="up"
wlans_run0="wlan0"
ifconfig_wlan0="WPA SYNCDHCP"
create_args_wlan0="wlanmode hostap"
create_args_wlan0="ssid CyberShoot mediaport hostap up"
create_args_wlan0="country RU"
hostap_setup_enable="YES"
#dhcpd_ifaces="wlan0"


#ifconfig_wlan0="ssid CyberShoot mediaport hostap up"

#hostapd_enable="YES"

#ifconfig_wlan0="inet 192.168.0.10 netmask 255.255.255.0"
defaultrouter="192.168.0.1"
#ifconfig_plip0="inet 192.168.0.10  netmask 255.255.255.0"
hostapd_enable="YES"
keymap="ru.koi8-r"
moused_enable="YES"
nfs_client_enable="YES"
nfs_server_enable="YES"
rpcbind_enable="YES"
sshd_enable="YES"
 


/boot/loader.conf
Code:
rt2870_load="YES"
#if_wi_load="YES"
runfw_load="YES"
if_run_load="YES"
wlan_tkip_load="YES"
wlan_xauth_load="YES"
#wlan_ccmp_load="YES"
#wlan_tkip_load="YES"

#if_config_rum0="WPA DHCP" 


/etc/hostapd.conf
Code:
interface=wlan0

logger_syslog=-1
logger_syslog_level=2
logger_stdout=-1
logger_stdout_level=2

debug=0

dump_file=/tmp/hostapd.dump

ctrl_interface=/var/run/hostapd
ctrl_interface_group=wheel

ssid=CyberShoot

wpa=3

wpa_passphrase=324622qaz

wpa_key_mgmt=WPA-PSK

wpa_pairwise=TKIP CCMP
 
 

PseudoCylon

Active Member

Reaction score: 19
Messages: 151

I'm little confused.
emir said:
roter dir-300 view rt2870 as wifi client
But you are setting rt2870 up as AP. Do you want to use rt2870 as client or AP?

And, what does it mean by "session not active"? It says wlan0 is up and running.
 
Top