Musca & Firefox problem


New Member

Messages: 2


I am relativliy new to bsd and musca, and got this strange behavioure after a while - got no idea what I did before this happend, it "just" happend :)

When I start firefox in a window (after a split) from xterm, firefox opens on the whole monitor and not in the frame where xterm is, the keyboard is in firefox for about 3 seconds, and then goes behind firefox back to the xterm, so I can not type in firefox, but in xterm that is behind firefox. Firefox is in fullscreen and the mouse is in firefox, so I can click on menus and pages. I want that firefox only opens in the frame and not over all frames with a working keyboard.

Have I accidently configured musca somehow? This only happens to firefox, not other programs.

Have a nice day


Active Member

Reaction score: 48
Messages: 224

I haven't used Musca, but it seems like the xterm window gets selected compared to firefox window. In ratpoison you can open some apps side by side, say a file manager and a terminal, unless the file manager window has been selected (normally with a key binding) you can't use the keys on that window. You can use the mouse, navigate the file menu and stuff, but typing won't work unless the window is selected.

This one seems like a musca configuration issue for sure. May be there is an option defined in the config to open firefox in fullscreen. So you should check that out and try some musca configs that should be available all over the net.



Reaction score: 6
Messages: 88

why don't you install dmenu & start all your apps from there (add a keybinding so you can run dmenu with a key combination), that way you want need xterm to start apps.

Also you can start firefox (any app) in xterm with "&" at the end of app name

firefox &

and close xterm after that


New Member

Messages: 2

Same thing if I run 'firefox3 &' from the dmenu with mod-x and no other windowsa - still no keyboard and whole a screen with firefox... should have mentioned that I have dualmonitor with nvidiadriver from ports, right now I have the Xinerama option, will experiment a little with the driver an try different modes.

Another strange thing is when I open a xterm with mod-t, the xterm sometimes do not come up, but flickers and dissaperes, and I have to hold down mod-t for 5 seconds to get an xterm, the I have 5 xterms under each other... exactly the same happens in xmonad, the terminal flickers and comes upp after some seconds in 5 new frames...