multimedia/mythtv port without DVB support

myso

Member

Reaction score: 2
Messages: 56

Dear community,

after a long time I decided to upgrade my multimedia/mythtv port from 0.27.x version to the latest available in the ports tree 0.28.7_2.

After this step everything broke, no more TV for my household.

I did investigate and found out I can't add any DVB Capture card, because there is no DVB option available within mythtv-setup.

It seems that the port is compiled without DVB support (can't locate using_dvb):
Code:
# /usr/local/bin/mythtv-setup --version
Please attach all output as a file in bug reports.
MythTV Version : ad97d24
MythTV Branch : tag: v0.27.5
Network Protocol : 77
Library API : 0.27.20141016-1
QT Version : 4.8.7
Options compiled in:
 freebsd profile using_jack using_oss using_backend using_bindings_perl using_bindings_python using_bindings_php using_frontend using_hdhomerun using_ceton using_hdpvr using_ivtv using_libcrypto using_libfftw3 using_libxml2 using_libudf using_lirc using_mheg using_opengl using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_taglib using_v4l2 using_v4l1 using_x11 using_xrandr using_xv using_profiletype using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_mheg using_libass using_libxml2 using_libudf
Also the versions reported byt mythtv-setup are odd, because:
Code:
# pkg info |grep mythtv
mythtv-0.28.7_2                MythTV is a homebrew PVR project
Anybody competent to help me resolve this issue? My wife's going to divorce me if no TV fairy tales are available during Christmas :(

Many many thanks

Mike
 

talsamon

Daemon

Reaction score: 281
Messages: 1,822

It is still version 0.27.5. The new version number, was caused by an attempt to update multimedia/mythtv by a wrong GH_TAGNAME (sorry, it was me). The committer never reverted this.

To enable it needs a hack of
/usr/ports/multimedia/mythtv/work/mythtv-ad97d24/mythtv/configure .
Only to change the CONFIGURE_ARGS in the Makefile ( --dvb-path="${LOCALBASE}/include/libdvbv5" and --enable-dvb) ends up after
make configure with:
Code:
DVB support               no [/usr/src/linux-10.4-RELEASE-p4/include]  <= cause this path does not exist on FreeBSD
DVB-S2 support            no
 
OP
OP
M

myso

Member

Reaction score: 2
Messages: 56

Hi talsamon, thanks.

I already tried the --enable-dvb argument and also came to the conslusion that it doesn't help, probably because of the incorrectly referrenced path:
Code:
DVB location needs to have linux/dvb/frontend.h [/usr/src/linux-11.1-RELEASE-p4/include]
Would you be so kind and supply me with some details on how to hack the configure file?

Many thanks.

Mike
 

talsamon

Daemon

Reaction score: 281
Messages: 1,822

I think it is too complicated to explain. In the moment I test the "old" update-patch. If it works I can attach it (on your own risk ;-))
 

talsamon

Daemon

Reaction score: 281
Messages: 1,822

A quick look said: "Sorry, no chance". Too much had changed in the meantime. (merge of graphic/openGL in graphics/mesa-libs, changes with qt, and changes of a lot of header-files). I had to make it new. And that's not possible in short time.
 
OP
OP
M

myso

Member

Reaction score: 2
Messages: 56

Guys, thanks for your efforts,

unfortunately the DVB support is still broken:
Code:
===>  Configuring for mythtv-0.27.5,1
DVB location needs to have linux/dvb/frontend.h [/usr/src/linux-11.1-RELEASE-p4/include]
# Basic Settings
Compile type              profile
Compiler cache            no
DistCC                    no
qmake                     /usr/local/bin/qmake
install prefix            /usr/local
runtime prefix            /usr/local
CPU                       x86 x86_64 (amd64)
yasm                      yes
MMX enabled               yes
MMXEXT enabled            yes
3DNow! enabled            yes
3DNow! extended enabled   yes
SSE enabled               yes
SSSE3 enabled             yes
AVX enabled               yes
FMA4 enabled              yes
CMOV enabled              yes

# Input Support
Joystick menu             no
lirc support              yes
libCEC device support     no [/usr/include]
Video4Linux support       yes
ivtv support              yes
HD-PVR support            yes
FireWire support          no
DVB support               no [/usr/src/linux-11.1-RELEASE-p4/include]
DVB-S2 support            no
HDHomeRun support         yes
Ceton support             yes
ASI support               no

# Sound Output Support
PulseAudio support        no
OSS support               yes
ALSA support              no
JACK support              yes
libfftw3 support          yes

# Video Output Support
x11 support               yes
xrandr support            yes
xv support                yes
VDPAU support             yes
VAAPI support             yes
CrystalHD support         no
OpenGL video              yes
MHEG support              yes
libass subtitle support   yes

# Misc Features
multi threaded libavcodec yes
libxml2 support           yes [/usr/local/include/libxml2]
libdns_sd (Bonjour)       no
libcrypto                 yes
Frontend                  yes
Backend                   yes
OpenGL ES 2.0             no
mythlogserver             no

# Bindings
bindings_perl             yes
bindings_python           yes
bindings_php              yes

# External Codec Options
mp3lame                   no
faac                      no
xvid                      no
x264                      no
vpx                       no
SDL                       no
 
OP
OP
M

myso

Member

Reaction score: 2
Messages: 56

Hello,

just to share information for future users of multimedia/mythtv on FreeBSD, I found a solution to all my troubles with multimedia/mythtv and multimedia/webcamd on FreeBSD (broken DVB support, broken special characters in my language - EPG program guide, very low DVB-T signal sensitivity, etc.).

The workaround (more probably a permanent solution in my case) is called Mythbuntu http://www.mythbuntu.org/ . The only downside is additional piece of hardware needed.

Good luck everybody and thanks to all who invested time and tried to help me to get it working.
 
Top