Multi user = stuck at logo. Single user = kernel panic

tl;dr I added 'snd_driver_load="YES"' and now I am stuck at freebsd logo with loud fans.

I haven't been able to get audio to work on my new FreeBSD 13-CURRENT install. I had basically tried everything, reconnected everything and pressed every google, bsd forum and bug tracker link and done every fix in these links to no avail. The last thing I found was to add snddriver_load="YES" and I think it was to /boot/loader.conf. After this, whenever I boot regularly (multi user as per default) I get stuck at the beastie/freebsd logo for eternity and my computer starts to make lots of sounds (the fans). I've had this issue once before but then I rebooted and everything was fine. Now I have tried rebooting 50 times, turned of the electricity to the computer, removed dust (dust was an issue once before), lowered my CPU voltage in BIOS, increased CPU voltage in BIOS, reset CPU voltage in BIOS (I was unable to boot into anything but Windows before because FreeBSD and every Linux variant gave me watchdog errors and other errors which overclocking fixed), etc, etc. Usually when I get boot errors I just boot into single mode and I mount / and undo the /boot/loader.conf or the /etc/sysctl.conf thing that I changed. This time though I get kernel panic and I end up at db> but there is no mouse control and the keyboard is not working. I can enable and disable numlock on my keyboard and the keyboard has backlighting but that is it.

I have encrypted swap and full disk encryption that I enabled in the GUI install.

Booting in from a FreeBSD USB stick and entering live CD mode and executing gpart show shows me:

=> 40 937703008       ada0 GPT (447G)
   40      1024       1 freebsd-boot (512K)
   1064     984       - free - (492K)
   2048 8388608       2 freebsd-swap (4.0G)
   8390656 929310720  3 freebsd-zfs (443G)
   937701376 1672       - free - (836K)

Is there any way to fix this? Can I boot into my USB -> Live CD mode -> Mount the encrypted SSD and remove the horrible changes I did? How'd I go about mounting an encrypted (which I believe I decrypt before I even get to the boot menu) SSD? I have some experience in formatting USBs and hard drives but I have little to no experience with ZFS and other things such as zpool, so you know where I stand.

I do not have ssh access so I cannot copy entire logs but I can copy what's important, in this case I literally wrote the gpart show output based on the output on my PC (I am writing this on another computer).
Ok I see that I obvisously missed a part of reading here. Mouning hard drive is easy on every Linux variant and all Windows releases but there is no documentation on how to mount a hard drive from a live USB. Can anyone send me in the right direction to learn how to mount hard drive from USB so that I can remove the edits in the configuration files :) Tysm

Doing mount -o ro /dev/ada0p3 /mnt does nothing because ada0p3 does not exist but it exists in ls /dev. Same result for every value "ada0p1, 2, 3" as well as ada0

Also I'll try the mailing list. Thanks for the tips guys.
The problem is not to mount the Z file system, the problem could be the encryption. Mounting a Z file system from a USB LIVE CD is easy: mkdir /tmp/zroot, zpool import -fR /tmp/zroot zroot (replace zroot if the name differs), zfs mount zroot/ROOT/default , edit loader.conf, zpool export zroot.

You can try to geli(8) attach the partition and execute the above commands.
I can create the directory but when I try to import zroot it gives me cannot import 'zroot': no such pool available. Every single time I boot, even into the USB, I've always entered the encryption key but now its gone. All threads on this forum is about people importing "pools" or whatever but I have not datasets or pools and creating one and mounting /dev/ada0 or zroot or any other combination I could find results in either errors or empty folders...

Also after executing your command (before any other attempts) and then rebooting because it gave me the mentioned error resulted in what I believe is a corrupt SSD. gpart show now outputs
ada0 GPT (447G) [CORRUPT]
but I have not datasets or pools and creating one and mounting /dev/ada0 or zroot or any other combination I could find results in either errors or empty folders...
Did you create a new zpool from that ada0 disk? If you did then I hope you have good backups, because you just wiped whatever that disk may have contained.
Can you try this:
kldload /boot/kernel/geom_eli.ko
geli attach /dev/ada0p3
mkdir /tmp/a /tmp/b
zpool import -o altroot=/tmp/a zroot # assuming zroot is your zpool name
# then you can mount your default BE
mount -t zfs zroot/ROOT/default /tmp/b