Mouse with PuTTY in Vim

Farhan Khan

Active Member

Reaction score: 11
Messages: 125

Silly question, when I am using PuTTY to my FreeBSD box and go into vim, if I try to click, it does not copy-paste text as it used to. Instead, it sends vim into visual mode or does some other arbitrary command.

How do I disable this and go back to default behavior?

If its something in ~/.vimrc, I would prefer keeping whatever settings are currently enabled minus the mouse integration.

Thanks!
 

aragats

Daemon

Reaction score: 709
Messages: 1,630

You have to add to your ~/.vimrc:
Code:
set mouse-=a
For some reason it doesn't work in the global one /usr/local/etc/vim/vimrc.
 
Top