Mouse(touchpad) works and does not work

I have a strange problem. On 10.3 I have setup touchpad as explained here:

It works fine if I start X by typing 'startxfce4' but I have 'slim' installed and after boot, at login screen touchpad doesnt work. Any ideas?

The other problem is I tried the xf86-input-synaptics and I have
hw.psm.synaptics_support="1" and moused is disabled
but it says (ironically one line before it says "synaptics touchpad found"
Unable to query/initialize Synaptics hardware
In dmesg |grep psm I see
psm0: model Synaptics Touchpad, device ID 0

When it works with startxfce4, it is working quite fine actually, even with 2 finger scroll etc. BUT when I try to click on an object and keep my finger on the button and move it. It does not work at all. Why would this happen?

OK here is the latest situation. With moused disabled and synaptics driver is set to use /dev/psm0 it loads fine actually. But the clicks do not function. I tried the clickpad (yes this is a clickpad, sorry that I forgot to mention) stuff and it doesnt help.

This seem to be related to FreeBSD's synaptics_support. Because clicks do not function properly on console with moused also. When I disable hw.psm.synaptics_support then immediately the touchpad is working properly.

But then the synaptics driver thinks it is not synaptics but mouse model 0 :) funny...

So, perhaps there is no solution then... :(