Mouse Prefreences in Mate Desktop

usakhncit

Active Member

Reaction score: 32
Messages: 241

Hi
I have migrated my first laptop (Samsung) to FreeBSD. Most of the things are working fine but some require fixing. One of them is touchpad. Although touchpad is working but not perfectly like palm detection. Under Mate Control Center, when I check "Mouse Preferences", I have noticed that it is showing only "Mouse" tab. The "Touchpad" tab is missing, eventhough I have enabled "moused" in rc.conf, so may I am missing some package which is required to detect touchpad properly in Mate Desktop. Kindly guide me to solve this problem. Thanks.
PS: Please check attached screenshot.
 

Attachments

  • mouse-preferences.png
    mouse-preferences.png
    51.5 KB · Views: 104

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,325
Messages: 38,841

What is the exact model of the laptop? And if you know, what is the model/type of the touchpad? Some touchpads just work, some require a little configuration and some aren't supported at all. Without knowing the hardware it's difficult to tell what you need to do.
 
B

badbrain

Guest


You enabled moused with which type? Try manually specify the protocol type.
 
OP
U

usakhncit

Active Member

Reaction score: 32
Messages: 241

SirDice, Laptop is "Samsung NP300E5Z". How would I know about touchpad model and its support in FreeBSD?
badbrain, I have used: moused_enable="YES", in /etc/rc.conf
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,325
Messages: 38,841

Laptop is "Samsung NP300E5Z".
Ok, that's useful, we can usually lookup what kind of hardware a specific model has. Somebody with the same laptop might be able to help too.

How would I know about touchpad model and its support in FreeBSD?
Have a look through the output of dmesg or read /var/log/messages. Is there any information referring to ums(4) or psm(4)?
 
OP
U

usakhncit

Active Member

Reaction score: 32
Messages: 241

dmesg |grep psm, shows following:
Code:
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model Elantech Touchpad, device ID 0
but, dmesg |grep ums, shows nothing.
 
OP
U

usakhncit

Active Member

Reaction score: 32
Messages: 241

I have used following settings in /boot/loader.conf:
Code:
hw.psm.synaptics_support="1"    # Enable Synaptic Support
hw.psm.elantech_support="1"
hw.psm.synaptics.touchpad_off="0"
hw.psm.synaptics.vscroll_div_max="150"
hw.psm.synaptics.vscroll_div_min="100"
hw.psm.synaptics.vscroll_min_delta="50"
hw.psm.synaptics.vscroll_ver_area="-600"
hw.psm.synaptics.vscroll_hor_area="0"
hw.psm.synaptics.taphold_timeout="125000"
hw.psm.synaptics.tap_min_queue="2"
hw.psm.synaptics.tap_max_delta="80"
hw.psm.synaptics.div_len="100"
hw.psm.synaptics.div_max_na="30"
hw.psm.synaptics.div_max="17"
hw.psm.synaptics.div_min="9"
hw.psm.synaptics.weight_len_squared="2000"
hw.psm.synaptics.weight_previous_na="20"
hw.psm.synaptics.weight_previous="6"
hw.psm.synaptics.weight_current="3"
hw.psm.synaptics.multiplicator="10000"
hw.psm.synaptics.window_max="10"
hw.psm.synaptics.window_min="4"
hw.psm.synaptics.na_left="1600"
hw.psm.synaptics.na_bottom="1408"
hw.psm.synaptics.na_right="563"
hw.psm.synaptics.na_top="1783"
hw.psm.synaptics.margin_left="200"
hw.psm.synaptics.margin_bottom="200"
hw.psm.synaptics.margin_right="200"
hw.psm.synaptics.margin_top="200"
hw.psm.synaptics.max_width="10"
hw.psm.synaptics.max_pressure="220"
hw.psm.synaptics.min_pressure="16"
hw.psm.synaptics.two_finger_scroll="0"
hw.psm.synaptics.directional_scrolls="0"
hw.psm.elantech.min_pressure=22"
hw.psm.elantech.two_finger_scroll=0"
hw.psm.elantech.vscroll_ver_area=0"
Now, touchpad is behaving a bit sensibly. But I want to completely disable, scroll, like vertical scroll or 2/3 finger scroll. Which values should i change?
Thanks
 
Top