Mouse & keyboard don't work after upgrade to X.org 7.4

borish

New Member


Messages: 15

Hi,

I'm posting this because I've seen that others had similar problems.

Today, I upgraded to FBSD 7.2. After starting the X-server, I noticed that neither mouse nor keyboard input worked.

The solution is to add the line

Option "AllowEmptyInput" "off"

in Section "ServerFlags".

I wonder what happened to X.org 7.4. Is it a new feature to disable mouse and keyboard by default?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,332
Messages: 33,894

It's because Xorg now relies on HAL to detect the mouse and keyboard.
This is different from previous versions.

Hence, you have to make sure hald is running before starting X.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,332
Messages: 33,894

borish said:
Is HAL just an annoyance or does it have any use
Learn to live with it. Gnome, KDE and Xfce all depend on HAL too.
 

ale

Daemon

Reaction score: 167
Messages: 1,059

The solution was here in the forum too, e.g. here

You can build xorg-server WITHOUT_HAL if you want.
 

BJwojnowski

Member

Reaction score: 1
Messages: 93

I have done some digging in the forum to find out why when I use startx on the FreeBSD system 8.2 the windows appear but there is no input from keyboard or mouse in the windows. In the digging I found several methods to possibly resolve the problem. It did not. What can I do?
 

wblock@

Beastie Himself
Developer

Reaction score: 3,685
Messages: 13,851

The Handbook X11 chapter advises using hal. The other option is to turn off AutoAddDevices in the ServerLayout section:
Code:
Section "ServerLayout"
...
        Option       "AutoAddDevices" "Off"
EndSection
 

BJwojnowski

Member

Reaction score: 1
Messages: 93

Problem Resolved

I rebooted and reinstalled FreeBSD and then place the hald and dbus enable lines in /etc/rc.conf and voila it worked. Thank you for your assistance.
 

masmidow

New Member


Messages: 6

Mouse Not Working

I have read all of the advise and tried all suggestions, but my mouse will simply not respond. May someone please assist me.

I am using gnome2 and the latest version of Xorg as of 10/13/2011. I have done the rc.conf hald and dbus lines.

Any assistance would be great. Do you need any more info?

Mike
 

wblock@

Beastie Himself
Developer

Reaction score: 3,685
Messages: 13,851

The Handbook mentions restarting after adding lines to enable dbus and hald to /etc/rc.conf. Did you do that, or start them manually?

If it's a PS/2 mouse, moused(8) is needed, too.
 
Top