Solved Mouse isn't working inside GNOME

neostanniy

Member

Reaction score: 1
Messages: 29

Hello everyone!

I have spent the last two days installing and setting up my FreeBSD with a great help of the Community here and here. And I finally managed to configure my X11, so I am now able to enter GNOME. Wheee! 😁

But there's always "but", you know. :) This time the issue is so weird, that I couldn't find a suitable answer neither on this forums, nor somewhere else on Internet.

My mouse works perfectly well inside the console, and it even works on gdm screen without any problems, but as soon as I log in into GNOME with my user -- it dies straight away. 🐭💀 The indication on mouse's body shows it's working, but I am able to move the cursor on the screen just for a second after login, and then this happens.

(AFAICS, the soundcard, which is PreSonus Audiobox 22VSL, is also ain't gonna work, but I'll try to fix it by my own as soon as I'll be able to use the mouse...)

I thought that it might be something wrong with the groups in which my user is, so I added him to the "operator" group (just in case), but still no result. Right now my user is in "wheel", "video", "operator" groups (and in the group of his name, of course). Am I on the right way? And what's actually going on?

Thank you in advantage!
 

George

Well-Known Member

Reaction score: 192
Messages: 484

I remember that similar issues (mouse not working in Xorg) were solved by setting a sysctl: kern.evdev.rcpt_mask=12. Or set it to 6. Maybe worth a try.
 
OP
neostanniy

neostanniy

Member

Reaction score: 1
Messages: 29

I remember that similar issues (mouse not working in Xorg) were solved by setting a sysctl: kern.evdev.rcpt_mask=12. Or set it to 6. Maybe worth a try.
Will try that and reply after. Thanks!
 
OP
neostanniy

neostanniy

Member

Reaction score: 1
Messages: 29

I remember that similar issues (mouse not working in Xorg) were solved by setting a sysctl: kern.evdev.rcpt_mask=12. Or set it to 6. Maybe worth a try.
Sorry for the delay.
No, that did't worked. Mouse is still unusable inside GNOME.
 
OP
neostanniy

neostanniy

Member

Reaction score: 1
Messages: 29

I also tried to log in with my root account choosing "Not listed" and typing the "root" name on the gdm screen. And I was able to use the mouse, but for some time only. I managed to open the "Settings" inside GNOME, moved to "Sound" just to make sure my soundcard isn't working (yeah, it isn't), and then at some point the mouse just... died.

What the hell is going on, I wonder... It's the strangest thing I have ever experienced. o_O
 

Trihexagonal

Son of Beastie

Reaction score: 2,070
Messages: 2,629

I have a Thinkpad T43, two T61, a T400, two W520 and a Gateway rebranded Acer laptop all running FreeBSD 12.2 and x11-wm/fluxbox as a WM.

I use a MS Optical Trackball mouse or a Razer Death Adder gaming mouse on all of them. The touchpad works on them all as does the Thinkpad Tracball keyboard thingy.

I install Xorg from ports and choose synaptics be installed but don't configure it, haven't got anything mouse related in /etc/rc.conf or done any editing of other files to get either of them to work on any machine.
 
OP
neostanniy

neostanniy

Member

Reaction score: 1
Messages: 29

I managed to solve this problem in a strangest way ever: I've deleted my user account with rmuser and added a new one using adduser. That worked... for some reason. :eek:
 

tingo

Son of Beastie

Reaction score: 627
Messages: 2,526

Makes sense: all you settings (for GNOME, and other GUI applications) are stored in subdirectories of the $HOME for your user, like $HOME/.config, $HOME/.local and so on.
Quick tip: the next time something like this happens, simply create another user and login with that user in Xorg. Then you know if the problem follows the user or if it is more ... global.
 
OP
neostanniy

neostanniy

Member

Reaction score: 1
Messages: 29

OK, the point is it was a temporary solution. F. e., at one time I can log in with my user and won't have any problems, but the next time I am getting back into the system and both my mouse and my USB sound card are dying (but the keyboard works all the time). But after a reboot it all works again... or doesn't... and it all goes on like this.

Is there any file like /etc/mood.cfg in FreeBSD? Maybe, that's an answer? 🙃
 
Top