Solved mount_smbfs works with Samba 4.4, not with 4.5

Hi all,

I have an SMB client (10.3-RELEASE-p11) and SAMBA server (11.0-RELEASE-p1) running samba43-4.3.13_2.
On the client I have /etc/nsmb.conf with stored credentials.

When I run:
# mount_smbfs -o ro -N //user@server/share /mountpoint

it works as expected.

This was also the case running samba44 (which no longer compiles due to a wscript error).

However after upgrading to samba45 or samba46, rather than a successful mount I get:
mount_smbfs: unable to open connection: syserr = Authentication error

  • this happens regardless of /etc/nsmb.conf or removing '-N' and entering the password on the command line
  • this happens regardless of using smbpasswd or tdbsam as the SAMBA password backend
  • non-FreeBSD clients (Kodi, MacOS) work fine on any SAMBA version

(Stripped) debugging the server when WORKING (4.3,4.4)
[2017/04/02 01:01:17.889027,  4] ../libcli/auth/ntlm_check.c:405(ntlm_password_check)
  ntlm_password_check: Checking NT MD4 password
[2017/04/02 01:01:17.892586,  2] ../source3/auth/auth.c:305(auth_check_ntlm_password)
  check_ntlm_password:  authentication for user [user] -> [INCOMING-01] -> [incoming-01] succeeded

when FAILING (>=4.5)
[2017/04/01 22:17:47.315437,  3] ../libcli/auth/ntlm_check.c:589(ntlm_password_check)
  ntlm_password_check: LM password and LMv2 failed for user incoming-01, and NT MD4 password in LM field not permitted
[2017/04/01 22:17:47.318823,  2] ../source3/auth/auth.c:315(auth_check_ntlm_password)
  check_ntlm_password:  Authentication for user [user] -> [INCOMING-01] FAILED with error NT_STATUS_WRONG_PASSWORD

Thanks LeeBrown66. That was it.

I tried fiddling with:
  • client lanman auth = yes
  • client NTLMv2 auth = yes
  • server min protocol = NT1

but none of these helped.

Hopefully this thread being documented helps someone else.