Solved mount_fusefs: /dev/fuse on /mnt/zroot2/zroot2: Operation not permitted

Hello to everyone.

Actually I've installed FreeBSD 14.0-CURRENT on my old PC and I'm trying to mount the folder that I have shared on the main PC via sshfs. This is the command that usually I give :

sshfs marietto@ /mnt/zroot2/zroot2

where is the IP of the main PC (where I'm running FreeBSD 13.2-RELEASE). What happens ? that sometimes it works,sometimes not. Below you see that today it does not work. I would like to know the reason of this behavior,taking in consideration that I don't change anything in the configuration from a day to another.

$ ./monta-server

mount_fusefs: /dev/fuse on /mnt/zroot2/zroot2: Operation not permitted

The authenticity of host ' (' can't be established.
ED25519 key fingerprint is SHA256:
This key is not known by any other names.
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes

(marietto@ Password for marietto@marietto:

marietto@marietto:/mnt/zroot2 $ cd zroot2

marietto@marietto:/mnt/zroot2/zroot2 $ ls


it seems the error is connected to fusefs. It may be affected by some kind of bug ? because on the main PC I have mounted the resource and I can see correctly the content of the shared folder. It is a zpool storage,so I do something like this :

# zpool import -f -R /mnt/zroot2 zroot2
# cd /mnt/zroot2/zroot2
# ls
ChatGPT Files   OS      bhyve
  • Thanks
Reactions: mro
I'd forgot to add kld_list="fusefs" to /etc/rc.conf ; I've been fooled because sometime it worked even without loading the kernel module,so I didn't even gave a look at rc.conf at all.