Mount Point of USB-Sticks

rfriemer

New Member


Messages: 5

Hello,

I'm just new as a Member, but have read a lot here in this forums ans got a lot of help. So, Thanks a lot for that.

Now, I have a Problem, which I couldn't found in the Internet and perhaps somebody could give me a hint.

I am using FreeBSD 13.0-RELEASE with Plasma5 and I have a Problem this mounting USB-Sticks. I do not use any mounting-tools. I want to use it only with the plasma GUI

I have formatted the USB-Stick with FAT32 and I have given them a label. I though in older versions the mountpoint would be /media/<Label> But I'm not sure.

Now, when I mount the USB-stick the mountpoint will be /media/<Serial-Information about the USB-Stick>, e.g.

Code:
/dev/da5s1 on /media/USB_SanDisk_3.2Gen1_01013f53f4d42b373cc34dd77948cd5a83b672977756d09418b55c3ace54a2b594200000000000000000
0000c8eb571000932a0083558107492a43f8_s1 (msdosfs, local)

My question s now, how can I change this?
Is it possible to use the Label?
Does somebody also has this Problem?

Or does anybody give me a hint, where to look?

Kind Regards

Robert Friemer
friem[media]
 

facedebouc

Member

Reaction score: 10
Messages: 58

You should find a device like /dev/msdosfs/label which can be mounted like this :
# mount -t msdosfs /dev/msdosfs/label /media/yourmountpoint
 
OP
R

rfriemer

New Member


Messages: 5

Hello facedebouc,

thank for this information. This is useful for a manual mount, but I want to have it autotmounted.

So, I have found something in the messages-log but I can not get the information where to look further

Code:
May 25 17:44:28 ... kernel: umass1: detached
May 25 19:46:28 ... kernel: ugen0.9: <SanDisk Ultra Luxe> at usbus0
May 25 19:46:28 ... kernel: umass1 numa-domain 0 on uhub1
May 25 19:46:28 ... kernel: umass1: <SanDisk Ultra Luxe, class 0/0, rev 3.20/1.00, addr 12> on usbus0
May 25 19:46:28 ... kernel: umass1:  SCSI over Bulk-Only; quirks = 0xc100
May 25 19:46:28 ... kernel: umass1:8:1: Attached to scbus8
May 25 19:46:28 ... kernel: da5 at umass-sim1 bus 1 scbus8 target 0 lun 0
May 25 19:46:28 ... kernel: da5: <SanDisk Ultra Luxe 1.00> Removable Direct Access SPC-4 SCSI device
May 25 19:46:28 ... kernel: da5: Serial Number 0101791c325b6987aa3f781f9e12808069b43ee14afb32fa840a95a66646
May 25 19:46:28 ... kernel: da5: 400.000MB/s transfers
May 25 19:46:28 ... kernel: da5: 58680MB (120176640 512 byte sectors)
May 25 19:46:28 ... kernel: da5: quirks=0x2<NO_6_BYTE>

The mountpoint for this USB-Stick is:

Code:
/dev/da5s1 on /media/SanDisk_Ultra_Luxe_0101791c325b6987aa3f781f9e12808069b43ee14afb32fa840a95a66646f84c730f00000000000000000
0001335af0c00146100a3558107c82627ab_s1 (msdosfs, local)

Is there a way to find the daemon doing the mounting in plasma5?

Is it possible to configure it?

Kind Regards

Robert
 

Trihexagonal

Son of Beastie

Reaction score: 2,423
Messages: 2,946

I've always mounted USB sticks manually and the only editing I do is create the /media/da0s1 directory first:

Code:
mount -v -t msdosfs /dev/da0s1 /media/da0s1

umount -v -t msdosfs /dev/da0s1 /media/da0s1

mount -v -t msdosfs -F32 -o large /dev/da0s1 /media/da0s1

umount -v -t msdosfs -F32 /dev/da0s1 /media/da0s1
 

Aeterna

Member

Reaction score: 30
Messages: 99

Hello,

I'm just new as a Member, but have read a lot here in this forums ans got a lot of help. So, Thanks a lot for that.

Now, I have a Problem, which I couldn't found in the Internet and perhaps somebody could give me a hint.

I am using FreeBSD 13.0-RELEASE with Plasma5 and I have a Problem this mounting USB-Sticks. I do not use any mounting-tools. I want to use it only with the plasma GUI

I have formatted the USB-Stick with FAT32 and I have given them a label. I though in older versions the mountpoint would be /media/<Label> But I'm not sure.

Now, when I mount the USB-stick the mountpoint will be /media/<Serial-Information about the USB-Stick>, e.g.

Code:
/dev/da5s1 on /media/USB_SanDisk_3.2Gen1_01013f53f4d42b373cc34dd77948cd5a83b672977756d09418b55c3ace54a2b594200000000000000000
0000c8eb571000932a0083558107492a43f8_s1 (msdosfs, local)

My question s now, how can I change this?
Is it possible to use the Label?
Does somebody also has this Problem?

Or does anybody give me a hint, where to look?

Kind Regards

Robert Friemer
friem[media]
While I don't have FreeBSD with KDE/Plasma, I think that KDE should make it ready for mounting when USB stick is connected. You should see a notification that stick is connected with the option to mount/open it. Then you can browse USB drive in Dolphin.
This is how it works in Slackware linux/Plasma (KDE) and FreeBSD probably.
I have FreeBSD with XFCE. When I connect USB it becomes visible and I have just to right click on the USB icon to mount it.
I think that by definition you will not see autmomounting windows-like style (completely without user interaction) which is expected.

I am not sure what do you need? Is your FreeBSD installed in VM? Then you have to make it available for VM client first in VM Manager.
 
OP
R

rfriemer

New Member


Messages: 5

Thank you for these help, but it didn't helped. I have installed sysutils/automunt, but it didn't change the mounting of the USB-Stick. See the screenshot.

See the Mountpoint /media/SanDisk_Ultra....

Mountpoint of USB-Stick.png


This is no ok when you copy multiple Forders.


There are no howtos or description in the Internet, so, I didn't found anything.

Does anybody has an idea?

Kind Regards

Robert Friemer
 
OP
R

rfriemer

New Member


Messages: 5

I got an update.

I do not know what happened and when, but now the Mounting is different.

Mountpoint of USB-Stick-28.05.2021.png



Now I have the situation, that the device-name, e.g. /media/da5s1 will be used as Folder, see Screenshot above. This is much better than the label. These folders can rest in the /media Folder.

The one Thing I can remember I did, was in the Systemsettings.

systemsetting-28.05.2021.png


I have activated the automatic Mounting in this dialogue (sorry it is in German).

So for me this issue is resolved.

Thank you for your help.

Robert Friemer
 
Top