Mount Galaxy S III

sigh

New Member


Messages: 12

Trying to mount a Galaxy S3 phone but unable to do so. From what I gather USB mass storage is no longer used and it must connect via MTP. Anyone know how to do this?

Thanks
 
OP
OP
S

sigh

New Member


Messages: 12

Unfortunately I'm pretty lost as to how to get this going. I installed mtpfs but am not sure which commands I'm suppose to be using with it. I ran mtpfs but I get "fuse: failed to open fuse device: No such file or directory". Is there a man page? man mtpfs produces nothing. How did you mount the galaxy ACE?
 

thegolum35

Member


Messages: 71

I didn't use mtps at all. When you plug your phone, a /dev/daX entry should appear. Then, turn on file sharing (I don't know the exact name in English) and /dev/daXs1 should have been created. So, mount it with mount -t msdosfs /dev/daXs1 /mnt

Gollum.
 

zeissoctopus

Active Member

Reaction score: 40
Messages: 167

sigh said:
Unfortunately I'm pretty lost as to how to get this going. I installed mtpfs but am not sure which commands I'm suppose to be using with it. I ran mtpfs but I get "fuse: failed to open fuse device: No such file or directory" Is there a man page? man mtpfs produces nothing. How did you mount the galaxy ACE?
You should:

1. enable FUSE support in /etc/rc.conf to load FUSE kernel module in every system startup
Code:
fusefs_enable="YES"
2. enable mount by user in /etc/sysctl.conf
Code:
vfs.usermount=1
After you connect the Galaxy S3 as MTP device to your FreeBSD, you can mount with mtpfs /mnt. Now, you can access the filesystem of Galaxy S3 under /mnt directory.

To umount your Galaxy S3, just do as follow umount /mnt
 
OP
OP
S

sigh

New Member


Messages: 12

Thanks @zeissoctopus, I can now mount my S3 but unfortunately only as root. When I mount it as a regular user it shows that it mounts but when I try to access the directory it tells me it's not a directory. I can mount and access USB drives fine as a regular user.
 
Last edited by a moderator:

micski

Member


Messages: 91

I followed the instructions by @Zeis @zeissoctopus [size=-1][presumably -- Mod.][/size] above. When I try to mount a Samsung Galaxy Note in MTP mode, I get the following error.

# mtpfs /mnt
Code:
Unable to open ~/.mtpz-data for reading, MTPZ disabled.Listing raw device(s)
Device 0 (VID=04e8 and PID=6860) is a Samsung Galaxy models (MTP).
   Found 1 device(s):
   Samsung: Galaxy models (MTP) (04e8:6860) @ bus 2, dev 4
Attempting to connect device
Unable to open raw device 40
Any hints?
 
Last edited by a moderator:

scottro

Daemon

Reaction score: 493
Messages: 1,398

I use a very minimal Linux in VirtualBox. The guide at http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/virtualization-host.html gives clear and simple instructions for enabling USB support.

I should probably add that I don't make much use of it -- if I were constantly transferring things back and forth, it might become a real nuisance to have to start VirtualBox, plug in the phone, and so on, but as it is, I only use it on rare occasions.
 

micski

Member


Messages: 91

For what it is worth, I found an alternative; I installed the File Manager application from the Play Store - and it included different network sharing features. An included feature is a LAN FTP server with configurable shared path and configurable anonymous and user accounts.
 
Top