• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

more_set_input_headers error with Nginx

Sirotz

New Member


Messages: 3

#1
Good Morning all,

I've used my google-fu and searched the forms but haven't found an answer to this error. I'm trying out nginx as a reverse proxy for Exchange and setup my config properly. I know for Linux "more_set_input_headers" requires "nginx-extras" or the "Headers_More" module in BSD.

I complied from source and made sure to select the "Headers_More" option. It is a fresh 11.1 azure install. Can anyone point me in a better troubleshooting direction? The exact error after restart is
Code:
nginx: [emerg] unknown directive "more_set_input_headers" in /usr/local/etc/nginx/conf.d/reverseproxy.conf:51
 

Sirotz

New Member


Messages: 3

#3
I did not. I thought building from source would include the module automatically. (Like statically adding modules to an install) Thanks for the suggestion. I will try it out in a little bit.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,099
Messages: 26,992

#4
Something changed recently, not sure when, but I noticed it with some other modules I use, they're not automatically included or loaded anymore. It seems the options only turn on (or off) the building of the modules but doesn't load or enable them.
 

Sirotz

New Member


Messages: 3

#5
Thanks SirDice! That did it. Yea, I wouldn't have gone down this path for awhile. I actually removed a pkg install thinking that compiling would include the module. Thanks again!
 
Top