Solved mongodb Warning: failed to start mongod

altyne

New Member

Reaction score: 1
Messages: 16

Well, seems the message is trival but the biggest issue I encountred. It has no logs created in /var/log.
1. created a jail.
(all actions took inside jail)
2. install: pkg install mongodb40
3. append /etc/rc.conf => with mongod_enable="YES"
4. service mongod start
5. Viola! Warning: failed to start mongod

But the questions, no logs created. How do i know what causes the error. I tried searching related guides (from google search) but still no success. BTW, if this not related to thread (Forums->Base System-> General). Let me know I'll mode it.
 
OP
altyne

altyne

New Member

Reaction score: 1
Messages: 16

I fixed my issue.

1. pkg remove mongodb40

2. Created /usr/local/etc/repos/FreeBSD.conf
FreeBSD : {
url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest",
mirror_type: "srv",
signature_type: "fingerprints",
fingerprints: "/usr/share/keys/pkg",
enabled: yes
}

3. pkg update -f

4. pkg intall mongodb40
 
Top