Mixer error

Levenson

Member

Reaction score: 8
Messages: 39

Well the mixer give me this

$ mixer
mixer: SOUND_MIXER_READ_DEVMASK: Device not configured

$ mixer -f /dev/mixer0
Mixer vol is currently set to 100:100
Mixer pcm is currently set to 100:100
Mixer speaker is currently set to 75:75
Mixer line is currently set to 75:75
Mixer mic is currently set to 100:100
Mixer cd is currently set to 75:75
Mixer rec is currently set to 100:100
Mixer igain is currently set to 50:50
Mixer ogain is currently set to 50:50
Mixer line1 is currently set to 100:100
Mixer line2 is currently set to 0:0
Mixer line3 is currently set to 0:0
Mixer dig1 is currently set to 0:0
Mixer dig2 is currently set to 0:0
Mixer dig3 is currently set to 0:0
Mixer phin is currently set to 0:0
Mixer phout is currently set to 0:0
Mixer video is currently set to 75:75
Recording source: mic


I think i should create a link with name mixer with the destination mixer0, but

ln -s /dev/mixer /dev/mixer0

doesn't work. what should i do? Is it possible to create link on the file with attribute "с"?

for ex i have some links

Code:
$ ls -la /dev/net*
lrwxr-xr-x  1 root  wheel         7 Dec 21 16:50 /dev/net1 -> net/sk0
lrwxr-xr-x  1 root  wheel         8 Dec 21 16:50 /dev/net2 -> net/fwe0
lrwxr-xr-x  1 root  wheel         9 Dec 21 16:50 /dev/net3 -> net/fwip0
lrwxr-xr-x  1 root  wheel         9 Dec 21 16:50 /dev/net4 -> net/plip0
lrwxr-xr-x  1 root  wheel         7 Dec 21 16:50 /dev/net5 -> net/lo0
crw-------  1 root  wheel    0,   3 Dec 21 16:50 /dev/network

/dev/net:
total 1
dr-xr-xr-x  2 root  wheel       512 Dec 21 16:50 .
dr-xr-xr-x  5 root  wheel       512 Dec 21 22:50 ..
crw-------  1 root  wheel    0,  55 Dec 21 16:50 fwe0
crw-------  1 root  wheel    0,  57 Dec 21 16:50 fwip0
crw-------  1 root  wheel    0,  92 Dec 21 16:50 lo0
crw-------  1 root  wheel    0,  69 Dec 21 16:50 plip0
crw-------  1 root  wheel    0,  43 Dec 21 16:50 sk0
 
OP
L

Levenson

Member

Reaction score: 8
Messages: 39

sorry mistake)
ln -s /dev/mixer0 /dev/mixer

and i'm forget to say that i'm doing this

sudo rm /dev/mixer

The link with other names creates perfectly but "mixer"..
 

Djn

Well-Known Member

Reaction score: 67
Messages: 392

The right way to do this is in /etc/devfs.conf - try link mixer0 mixer .

I'm not entirely sure what the right way to reload these things on the fly is, but mount -t devfs none /dev seems to work.
 
OP
L

Levenson

Member

Reaction score: 8
Messages: 39

Djn said:
The right way to do this is in /etc/devfs.conf - try link mixer0 mixer .

I'm not entirely sure what the right way to reload these things on the fly is, but mount -t devfs none /dev seems to work.

Thanks, but it doesn't work for me. After mounting, /dev/mixer creates again. And it's not a link to /dev/mixer0

I add to devfs.conf
link mixer0 mixer_test and it's work perfectly. The problem is that i can't create link with the name mixer in /dev
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,357
Messages: 38,883

Djn said:
I'm not entirely sure what the right way to reload these things on the fly is, but mount -t devfs none /dev seems to work.

/etc/rc.d/devfs restart ;)
 
OP
L

Levenson

Member

Reaction score: 8
Messages: 39

Thanks for all. I did it. I have delete oss and after restart it's begin working.
 
Top