Solved Missing hald and dbus deamon

Missing Hald deamon. But i was install hal from pkg. Now is black screen when i want to run Xorg and Xorg -c back (EE) error :/ Its something wrong..
Of course. I do it not first time. Another problem. Pkg can't find signature. few minits ago pkg is working I install it from memstic iso downloaded from official site... leater upload photo...
I thing the same. I traing erase with zero and random data now... Any idea how to burn hirensboot into memstick using FreeBSD? DD not working...
I don't use ubuntu since around 2005 (I think), but for Linux in general you can use dd. The SquashFS is a hybrid, for CD and memstick. You may try to use this one.

EDIT: or if you prefer something with a gui, Manjaro is faster than ubuntu.
What was happend... I destory hardware raid and install FreeBSD from memstick now ubuntu is downloading using Links browser... Xorg still not working. Blackscreen.

Edit. Ubuntu have huge package of drivers.
Mint is better.
I cant use any GUI because Xorg not working. I want to reinstall base system because I do mistake and i broke PKG some times ago, I'm study now and i must have NTFS FS and maeby HP printer. I have huge problem with security too. But I am Never Back Down. And somebody is scared. :) Finally i'll be used OpenBSD or somethig like that.

Edit. Ubuntu stand up.
It is easy to fix pkg:

pkg prime-list > list (to save your origins files)
pkg delete all files in the list
pkg autoremove (remove all installed packages)
rm -rf /var/db/pkg/*

Then install the origin packages in the list file again.

print/hplip is in the ports collection, and you can use sysutils/fusefs-ntfs

EDIT: if there is nothing hard depending on sysutils/hal, you can also ditch hal and use sysutils/automount to automount, with very little configuration.

There is a built in automount what use AutoFS but never worked for me: Thread 60282
So, just one question are you using the nvidia blob? Had you added in nvidia_load="YES" or nvidia-modeset_load="YES" in /boot/loader.conf?
Nope I use Intel integral graphic compare with Intel I5 2520M On Optimus HP8460p motherboard. But wat was happend i do everythig correct. Create partition, create IPFW rules. Connection to the web install Xorg and then bum. Sabotage, backdor or what. I do not know what think about it.
Ok, have you tried disabling one of those cards in the BIOS/UEFI? There were some people with this kind o problem solved by disabling one of them.

EDIT: Never mind, I saw optimus and thought about nVidia Optimus.
Nope sorry nevermind is only Dictionary. I tried few installation using diffrent package server. Russian US UK. Olways the same...

I will tried it but for some wile...

I was install FreeBSD on this HP and this configuration lot of time and this problem is seeing first time. I am not newbie on UNIX like Operating System And I'm sure something is wrong.
Just a few quick things before leaving:

If you are using RAID in a laptop it is almost certainly not a hardware RAID. If you need/want to use RAID better disable it on BIOS/UEFI and use ZFS instead. If you are already using ZFS, it is not a good idea to use ZFS with hardware RAID (search on the forum), and even worse on the top of software RAID. If you insist to use the laptop RAID, use UFS and not ZFS.

ports-mgmt/pkg is not part of the base system, it is bootstrapped at the first time you use it. If somehow pkg is broken to the point you cannot backup the origin file list and/or everything is messed up, you can ever "reset" the FreeBSD installation:

rm -rf /usr/local
mkdir /usr/local && cd /usr/local
mtree -deU < /usr/ports/Templates/BSD.local.dist
rm -rf /var/db/pkg/*
rm -rf /var/db/ports/

Cheers! :beer:
Solved. I was install FreeBSD using Memstick.img, and download and install Links browser, then download DVD iso package from official site mount it and install NOT BROKEN X Window System - it was brilliant.

But still I do not know why somebody CHANGE and broke Xorg (and in fact Operatin System) package in the official repository.

Thanks for help... see You later and I hope if Nobody was NEVER implemented ANY backdor on this system, Ceep it, Peace And Love.

PS. Some photo, like I'am say:

Broken instaltion from official repository.

Broken Ports Tree (compiling?) after update it using portsnap fetch && extract

Unexceptial date update Xorg on the official PKG tree why Somebody change (update) working package from 2016??

Do not touched source from 2016!!

I Am not alone, i think.

How to mount ISO.

How to install offline package.

Of course everything is "case". But Thanks so much for work on this OS. It means a lot to me. I'm study Now. I do not have time to fully analize it....

PS2 I still use German Proxy with opera on VirtualMachine.
Are you somehow trying to mix ports and pkgs? It is not a good idea, and usually do not end well. Also pkg come configured to use quarterly packages, and not latest, and ports are in general still newer than the latest packages.

If you value more stability than updates, stick with quarterly.

Xorg was upgraded recently but the problems, at least almost of them, are already solved now. Also, unless you have a problem or a specific need you do not need it, and it is not advisable to use a xorg.conf in general.

If you are building from ports, better use ports-mgmt/synth or ports-mgmt/poudriere to do it. As reference Synth and Poudriere.

With the amount of weird random problems you are experiencing, I do believe you have hardware problems, it seem so memory issues - or at least low memory. Do check disks and memory.

FreeBSD uses memory differently than other systems, what means your memory may have problems since years and never appear on Linux/Windows but give you a lot of headache on FreeBSD.

Again, take a look on what I said before about RAID and ZFS, if you are using RAID and ZFS.

If you are using a custom make.conf, remove it and try to make the things work with the default settings, and without using -j with make.

And do not forget to carefully read the FreeBSD Handbook.
Too many coincidences. I use mostly PKG is faster. I do not use FreeBSD from Yesterday read manual and i am know what I am doing (for example my another Xorg topic). And fact is so clean, and documented. (my iqto) Cannot install Xorg using PKG, and A N O T H E R (Not hardware) of installation is broken after update, then Cannot Compile program from Ports Tree. Wonderful rejuvenation when I'am install Xorg window system using older "Rock And Stable" package Version. Case? Dont be silly. :)

But what is reason? Disgusting ppl to FreeBSD?? Too hard for stalking???? Here I will not know it. :)
Give a try to synth just to see what happens. It build packages in a clean env and not the Live one.

EDIT: what FreeBSD version are you using. Just in case CURRENT is bleeding edge - it is expected to often break, STABLE is a development also can break often. So, if you are using one of those, try moving into RELEASE, what is the real stable version.