Solved milter-greylist broken Makefile

trev

Daemon

Reaction score: 302
Messages: 1,027

I rebooted a Digital Ocean droplet of FreeBSD 10.1-Release and was met with milter-greylist failing to start due to not having been compiled for GeoIP use.

So, I went to ports, tried make config and sure enough, the GeoIP option was already selected. A new compile later and still the same issue.

Not being a Makefile genius, I edited the Makefile to add:

Code:
CONFIGURE_ARGS+=  --with-user=mailnull \
  --with-libmilter=${MILTERBASE} \
  --enable-dnsrbl \
  --with-thread-safe-resolver \
  --with-libGeoIP=${LOCALBASE} \  <<<<<-------------
  --with-dumpfile=/var/milter-greylist/greylist.db
which solved the immediate issue.

On a closer look at the Makefile there is an anomaly with the number underscores for the GeoIP configure option:

Code:
DKIM_CONFIGURE_WITH=  --with-libdkim=${LOCALBASE}
SPF_CONFIGURE_WITH=  --with-libspf2=${LOCALBASE}
GEOIP__CONFIGURE_WITH=  --with-libGeoIP=${LOCALBASE} <<<<--------
CURL_CONFIGURE_WITH=  --with-libcurl=${LOCALBASE}
LDAP_CONFIGURE_ON=  --with-openldap=${LOCALBASE}
LDAP_LDFLAGS=  -L${LOCALBASE}/lib
LDAP_USE=  OPENLDAP=yes
which may be the real issue. Unfortunately I needed to get my droplet up and running again so I have not tested this.
 

kpa

Beastie's Twin

Reaction score: 1,853
Messages: 6,318

It most certainly is an error introduced by fat fingering and the ports framework has no way of detecting such errors unfortunately.
 
Top