Midnight Commander on Mate desktop 12.2 & 13.0

dalpets

Well-Known Member

Reaction score: 15
Messages: 342

MC tries to load onto the desktop but is unsuccessful. Is this a bug? Is there a workaround?
 

balanga

Son of Beastie

Reaction score: 201
Messages: 3,829

MC tries to load onto the desktop but is unsuccessful. Is this a bug? Is there a workaround?
Not sure what you mean.... If you open a terminal and run mc, what happens?

I run it all the time. I currently use lxde and have no problem.
 

bobmc

Member

Reaction score: 15
Messages: 51

I found that starting it from user account does not work unless "mc -u"
I don't know why.
 
OP
D

dalpets

Well-Known Member

Reaction score: 15
Messages: 342

Not sure what you mean.... If you open a terminal and run mc, what happens?

I run it all the time. I currently use lxde and have no problem.
command not found (@ root) -:(
 
OP
D

dalpets

Well-Known Member

Reaction score: 15
Messages: 342

On 13.0 I just noticed that I got the following message on installation of mc.

'Note that the stack overflow handling functions of this library need
procfs mounted on /proc'
Could this be the problem? What would be the full entry in /proc
 

Alexander88207

Well-Known Member

Reaction score: 261
Messages: 470

'Note that the stack overflow handling functions of this library need
procfs mounted on /proc'
Could this be the problem? What would be the full entry in /proc

Hello,

to mount procfs on /proc you need to do the following:

mount -t procfs proc /proc

To make it permanent, you need the following line in /etc/fstab:

proc /proc procfs rw 0 0
 

balanga

Son of Beastie

Reaction score: 201
Messages: 3,829

command not found (@ root) -:(
Does /usr/local/bin/mc exist? That's where it should be installed. If it's there and you can't run it then it sounds like a permissions problem. Are you root?
 
OP
D

dalpets

Well-Known Member

Reaction score: 15
Messages: 342

Y
Does /usr/local/bin/mc exist? That's where it should be installed. If it's there and you can't run it then it sounds like a permissions problem. Are you root?
Yes it exists with the following permissions;
owner=root
group=wheel
permissions=read & write.
I managed to launch mc @ root after getting write permission with xterm chown but the file (sh) has only unintelligible ^@'s.
I'm struggling with permissions at the moment. What is the proper octal to get user permission? Thanks.
 

balanga

Son of Beastie

Reaction score: 201
Messages: 3,829

Y

Yes it exists with the following permissions;
owner=root
group=wheel
permissions=read & write.
I managed to launch mc @ root after getting write permission with xterm chown but the file (sh) has only unintelligible ^@'s.
I'm struggling with permissions at the moment. What is the proper octal to get user permission? Thanks.
You could run chmod 777 /usr/local/bin to see if it makes any difference.. also start mc using mc -a or mc -c which might make it more intelligible
 

jmos

Active Member

Reaction score: 116
Messages: 159

Yes it exists with the following permissions;
owner=root
group=wheel
permissions=read & write.
You have messed up your file permissions. A binary needs the executable flag (but no write permission). Reinstall your Midnight Commander package, that should fix it: pkg install -f mc
 
OP
D

dalpets

Well-Known Member

Reaction score: 15
Messages: 342

You have messed up your file permissions. A binary needs the executable flag (but no write permission). Reinstall your Midnight Commander package, that should fix it: pkg install -f mc
Thanks for your help, particularly re the flag issue. It now works.
 
OP
D

dalpets

Well-Known Member

Reaction score: 15
Messages: 342

You could run chmod 777 /usr/local/bin to see if it makes any difference.. also start mc using mc -a or mc -c which might make it more intelligible
Thanks for your help, it works now. It looks like the (Mate) Applications Places System is trying to put xterm on the desktop to open mc but it doesn't succeed in doing so. Not a big deal, but it is inconvenient to have to go to root/xterm to open it when working as a desktop user. In other words mc will only open in the root environment.
I assume that when going to root with xterm that the desktop stays in user mode, regardless, if it was there before going to root?
 

balanga

Son of Beastie

Reaction score: 201
Messages: 3,829

I've never used Mate, I Iike LXDE which is nice and simple. You click on the Applications menu and up pop numerous categories including System Tools and by some magic when you install mc it automatically appears in that category, although I personally like to open LXTerminal and run it from there.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,991
Messages: 36,924

You could run chmod 777 /usr/local/bin to see if it makes any difference..
No, No, NO. NEVER ever do this. Not even to try. It's utterly useless and dangerous!
 
Top