Solved mDNSd fails to start

HiddenWolf

Member


Messages: 22

I've just installed mDNSResponder on a FreeBSD 10.2 jail.
The port has no user-configurable options that I can find, and no switches.

However, when I start it, it fails to come up:
# mdnsd -debug
Code:
mDNSResponder (Engineering Build) (Feb  1 2016 17:40:48) starting
socket AF_INET6: Protocol not supported
mDNS_AddDNSServer: Lock not held! mDNS_busy (0) mDNS_reentrancy (0)
mDNSResponder (Engineering Build) (Feb  1 2016 17:40:48) stopping

The host is configured to use IPv6, the jail is not, and has only an IPv4, an alias of my LAN interface:
ifconfig
Code:
em0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500

    options=40098<VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,VLAN_HWTSO>

    ether 00:25:90:86:be:9a

    inet 10.0.0.220 netmask 0xffffffff broadcast 10.0.0.220

    media: Ethernet autoselect (1000baseT <full-duplex>)

    status: active

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384

    options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>

tap0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500

    options=80000<LINKSTATE>

    ether 00:bd:63:6c:00:00

    media: Ethernet autoselect

    status: active

    Opened by PID 1184

bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

    ether 02:89:4b:73:89:00

    id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15

    maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200

    root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0

    member: tap0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>

            ifmaxaddr 0 port 3 priority 128 path cost 2000000

    member: em0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>

            ifmaxaddr 0 port 1 priority 128 path cost 20000

Any suggestions on how I get this set up?
 

cpm@

Moderator
Staff member
Moderator
Developer

Reaction score: 950
Messages: 2,140

Did you have mDNSResponder daemon enabled in /etc/rc.conf?
Code:
mdnsd_enable="YES"
Read mdnsd(8) manpage for further details.
 
OP
H

HiddenWolf

Member


Messages: 22

I do.

/etc/rc.conf
Code:
### Various
zfs_enable="YES"            # Enable ZFS
hostname="backup"            # hostname
defaultrouter="10.0.0.2"        # set default route  
kern_securelevel_enable="YES"        # Enable 'securelevel'
kern_securelevel="1"            # See init(8)
cron_flags="$cron_flags -J 15"        # Prevent jails from running cron concurrently
syslogd_flags="-ss"            # Disable syslogd listening


### Mail
sendmail_enable="NONE"

### Services
netatalk_enable="YES"
afpd_enable="YES"
mdnsd_enable="YES"

mdnsresponder_enable="YES"
mdnsresponder_flags="-f /usr/local/etc/mdnsresponder.conf"
 

cpm@

Moderator
Staff member
Moderator
Developer

Reaction score: 950
Messages: 2,140

I've misread your first comment. A similar question was raised in Forums. Please, read Thread 43270.
 
OP
H

HiddenWolf

Member


Messages: 22

EDIT: Solved.
After juggling a few options and restarting the various services in every possible order, things are now working as expected.
 
Top