Matplotlib python3 anyone?

yggdrasil

Member

Reaction score: 7
Messages: 55

Hi,

has anyone managed to actually build the math/py-matplotlib port with some version of python 3? The history on freshports mentions that some time ago it couldn't be built without human intervention due to some other ports build failures. Unfortunately I can't find any description on how to actually do this.
My tries with make PYTHON_VERSION=3.{3,4,5} always end with
Code:
* The following required packages can not be built:
* gtkagg, gtk
even when I disable the GTK backends in make config. Anyone successful with this?

Thank you.
 

tobik@

Daemon
Developer

Reaction score: 1,377
Messages: 1,909

has anyone managed to actually build the math/py-matplotlib port with some version of python 3?
Yes, that works fine with Python 3.5 here. Both with the port and via pip3 install --user matplotlib. In the port I disabled all options.
 
OP
OP
Y

yggdrasil

Member

Reaction score: 7
Messages: 55

Wow, now I'm really starting to question my sanity... So far a pip install matplotlib within a python3.5 virtualenv always failed, which was the reason I tried buidling it via ports in the first case. Now a pip3 install matplotlib in the same venv just works?! Even though in the venv pip is the same as pip3 (according to pip --version.

edit
And now I understand why: matplotlib can be installed just fine via pip, just not its dependencie numpy. I had to build that one via ports, because during pip install numpy it fails with a
Code:
cc: error: linker command failed with exit code 1
, then copy it from the system site-packages to the venv's site-packages. Then matplotlib could be installed via pip just fine.
 

NOP

New Member


Messages: 3

Maybe a bit late, but after having similiar problems when trying to install py-matplotlib for python3.5 from ports, I finally succeeded by explicitly disabling the GTK backend via make option AND config menu:
make install clean PYTHON_VERSION=python3.5 GTK_BACKEND=False
(In the config-menu I kept the Tk backend but disabled the Gtk-/GtkAgg options).
 
Top