Solved Mate not working properly after updating to 1.28

After yesterday's system update, specifically the mate graphical environment, it's up to 1.28. I have problems with its operation. All widgets on the panel have disappeared and a window like the one below appears for each one. no matter what I click, the effect is the same. I haven't been able to add any applet again, apart from the Mate Menu

The problem is on the current user(yampress) after updating to the latest mate with the mate 1.26 configuration that I use.
The same problem also occurs on the new user "test" which I created and mate started on a clean configuration

oot@freebsd /home/test # freebsd-version
root@freebsd /home/test # uname -a
FreeBSD freebsd 14.0-RELEASE-p6 FreeBSD 14.0-RELEASE-p6 #0: Tue Mar 26 20:26:20 UTC 2024 amd64
root@freebsd /home/test #


root@freebsd /home/test # pkg info |grep mate
libmatekbd-1.26.0_2 MATE keyboard shared library
libmatemixer-1.28.0 Mixer library for MATE desktop
libmateweather-1.28.0 Library to access online weather information
mate-1.28.1 "meta-port" for the MATE integrated X11 desktop
mate-applets-1.28.0 Applets components for the MATE Desktop Environment
mate-backgrounds-1.28.0 Collection of backgrounds for MATE
mate-base-1.28.1 "meta-port" for the MATE base integrated X11 desktop
mate-calc-1.28.0 MATE calculator tool based on the old calctool for OpenWindows
mate-control-center-1.26.0_6 Control center for MATE project
mate-desktop-1.28.1 Additional UI API for MATE
mate-icon-theme-1.28.0 Collection of icons for the MATE desktop
mate-media-1.28.1 Multimedia applications for the MATE desktop
mate-menus-1.28.0 Implementation of the FreeDesktop Desktop Menu Spec
mate-notification-daemon-1.28.0 Send small notifications to your desktop
mate-pam-helper-1.3 MATE authenticate applications requiring PAM services
mate-panel-1.28.0,1 Panel component for the MATE Desktop
mate-polkit-1.28.1 MATE frontend to the PolicyKit framework
mate-power-manager-1.28.1 Power management system for the MATE Desktop
mate-screensaver-1.28.0 MATE screen saver and locker
mate-session-manager-1.28.0 Session component for the MATE desktop
mate-settings-daemon-1.28.0 MATE settings daemon
mate-system-monitor-1.28.1 MATE system monitor program
mate-terminal-1.28.1 Terminal component for the MATE Desktop
mate-themes-3.22.23_1 Collection of themes and icons for MATE
mate-user-guide-1.28.0 MATE users guide
mate-utils-1.28.0 MATE support utilities
root@freebsd /home/test #
I encountered the exact same problem after upgrading packages yesterday. I have been using mate 1.28 for a few weeks without a problem. Some of the mate packages seem to be taking longer to be built as packages. Most of the packages for 1.28 have been available for a few weeks. Yesterday I noticed the following updates:

mate-icon-theme: 1.26.0 -> 1.28.0 [FreeBSD]
    mate-menus: 1.26.0 -> 1.28.0 [FreeBSD]
    mate-panel: 1.26.2_4,1 -> 1.28.0,1 [FreeBSD]

I suspect mate-panel may be causing the problem. I don't know how to solve it. I have switched back to xfce until there is a new update that solves the problem.
There is something broken with some GNOME/GTK dependencies cause my XFCE doesn't even load.

I am pretty sure GNOME users aren't affected at all... 🤔
I don't have a problem with xfce. That's working fine for me. A temporary solution is to remove mate-panel and re-install the older version from /var/cache/pkg/mate-panel-1.26.2_4,1. This seems to solve the above problem. You will need to lock the package, so that it doesn't upgrade to 1.28 next time you do a package upgrade.
I removed the new mate-panel-1.28, installed the old mate-panel-1.26 with cache
and everything seems to be working properly.

root@freebsd /home/yampress # pkg lock mate-panel
mate-panel-1.26.2_3,1: lock this package? [y/N]: y
Locking mate-panel-1.26.2_3,1
Now you have to wait for an update that fixes the above error.
I ran into this issue with my MATE desktop running on openSuse. I saw some posts about other Linux distros having the same issue with MATE 1.28.2. A few posts mentioned installing dconf-editor. I tried it on my openSuse VM and it resolved the issue. On a whim, I tried the same on my FreeBSD VM and it also resolved the issue there as well.

pkg install dconf-editor
I ran into the same problem yesterday, when I upgraded the system from FreeBSD 13.2 to 14.0. Exactly the same as shown in the screenshots above. But what I found out that neither the "mate" metaport package nor the "mate-terminal" (and probably much more) were installed, because they don't seem to be in the 14.0 quarterly package server! Tested it with pkg search.
So not even a pkg install mate or pkg install mate-terminal works!
I would like to know if this will be looked into and if the packages will be available, soon?
So not even a pkg install mate or pkg install mate-terminal works!
I would like to know if this will be looked into and if the packages will be available, soon?
Unfortunately, at least graphics/eom and x11/mate-terminal often (and not always for the exactly same commit) fails to build, due to the crash of textproc/itstool which is used for builds. Not always crashes. Looks quite racy.
Maybe official pkg builder is bitten by it.
On local builds, repeated desintalling and rebuilding textproc/itstool and redoing whole rebuilds helps for bare-metal environment.
For clean-room builders like ports-mgmt/poudriere, deleting already built textproc/itstool does the same. Need repeats until succeeds.
For me, usually 1 to 5 attempts helps, but if you are unlucky, possibly 10, 100 or more attempts could be required. Sigh.