Marvell Yukon 88E8056 Gigabit Ethernet

felix

Member

Reaction score: 18
Messages: 20

System - FreeBSD 6.3-RELEASE-amd64 or FreeBSD 7.0-RELEASE-amd64.

Dont work onboard Marvell Yukon 88E8056 Gigabit Ethernet, some messages from dmesg are like:

msk0: watchdog timeout

ifconfig:

media: Ethernet autoselect (1000baseTX <full-duplex>)

Could you please tell me how to solve this problem.
Thanks!
 

andygui

New Member


Messages: 5

slapsh said:
Replace Marvell to Intel or Broadcom. Marvell actually don't work on FreeBSD.
This is simply not true. I have a server running 7.0-STABLE with a Marvell Yukon 88E8050 that has been serving hundreds of gigs a month just fine.

felix: You may want to contact Pyun YongHyeon (yongari/at/freebsd.org), as he resolved all of the issues that I originally encountered when trying to get this NIC working on FreeBSD (IIRC, they were MSI and TCP checksum offloading issues).

Best of luck!
 

BlackSteel

New Member


Messages: 4

88E8056 under 7.1-PRERELEASE. MB: ASUS P5K-VM

1)Watchdog timeouts under high load with msk driver.
even with hw.msk.msi_disable=1
2)with myk driver:
a)with txcsum and rxcsum enabled it doesn't works at all
b)with txcsum and rxcsum disabled it works, but fails under high load with different error messages.

I haven't found any working solution.
 

tbyte

Active Member

Reaction score: 2
Messages: 119

BlackSteel said:
88E8056 under 7.1-PRERELEASE. MB: ASUS P5K-VM

1)Watchdog timeouts under high load with msk driver.
even with hw.msk.msi_disable=1
2)with myk driver:
a)with txcsum and rxcsum enabled it doesn't works at all
b)with txcsum and rxcsum disabled it works, but fails under high load with different error messages.

I haven't found any working solution.
Same observed with ASUS M3A78-T's 8E8056 under 7.1-PRE. And even worst - if_msk directly panics/halt/reboots the system.
 

edhunter

Member

Reaction score: 10
Messages: 71

Try this utility http://www.marvell.com/drivers/files/yukondg_v6.53.4.3.zip - it can flash Yukon's firmware and I think it can set some settings.

&quot said:
Marvell shipping broken firmware is completely unpublicised or acknowledged, however updated firmware is available through your
motherboard vendor, so all hope it not lost after all...
May be you could find somewhere newer firmware and try to flash it on your nic...

stargazer said:
My Marvell 88E1011 Ethernet is working perfectly:\
stargazer, could you save your firwmare to file (using this utility) :) And then share it with us. I also have in one of my machines marvell 88exxxx (dont remember the exact number now) making troubles.
 

copremesis

New Member


Messages: 1

update on marvell yukon

looks as if this problem surfaced when attempting to update the memory on my FreeBSD box .... crappy AMD 64 acre is to blame ...
try reducing your mem and it might all of a sudden work ... it's because there are too many interrupts ocurring or something like that ....
 

hydra

Well-Known Member

Reaction score: 27
Messages: 272

That's strange, I've been using this device with amd64 for a while now without any problems...
 
Top