make dolphin quiet about permissions errors

romanaOne

Member

Reaction score: 9
Messages: 78

I'm using autofs with KDE5 (hald isn't installed) and whenever I copy anything to a FAT formatted usb drive I get one warning dialog per file copied about being unable to set permissions, presumably because I'm copying from ZFS to FAT32 which doesn't have permissions.

So If I drag a folder with 10 items into a USB drive I get 10 error dialogs, each one of which requires a click on OK. One time, I forgot and dragged a folder with thousands of items onto a USB drive, which froze the KDE GUI.

Is there some way to get dolphin to not to complain about permissions? I've noticed other file managers (rox, xfe) also complain about permissions with these silly dialog boxes. Only rox has a "quiet" option to avoid having to click OK thousands of times.
 

ShelLuser

Son of Beastie

Reaction score: 1,676
Messages: 3,511

It's a well known issue, but unfortunately it's not Dolphin but the underlying OS which causes this. Depending on the used filesystem (and the way you mounted it) there might be an option to set it to a more quiet mode.
 
OP
OP
R

romanaOne

Member

Reaction score: 9
Messages: 78

I've got
Code:
/media          -media          -nosuid,noatime,-m=770,-L=en_US.UTF-8
in /etc/auto_master.

A typical USB stick:
Code:
>fdisk da0

******* Working on device /dev/da0 *******
parameters extracted from in-core disklabel are:
cylinders=3880 heads=255 sectors/track=63 (16065 blks/cyl)

Figures below won't work with BIOS for partitions not in cyl 1
parameters to be used for BIOS calculations are:
cylinders=3880 heads=255 sectors/track=63 (16065 blks/cyl)

Media sector size is 512
Warning: BIOS sector numbering starts with sector 1
Information from DOS bootblock is:
The data for partition 1 is:
sysid 12 (0x0c),(DOS or Windows 95 with 32 bit FAT (LBA))
    start 8192, size 62325760 (30432 Meg), flag 0
        beg: cyl 0/ head 130/ sector 3;
        end: cyl 1023/ head 254/ sector 63

If I copy a file cp ~/test /media/stick/test, there is no error; that's what made me think it is a filemanager thing.
 

Vull

Active Member

Reaction score: 93
Messages: 224

(hald isn't installed)
I know a lot of people are reluctant to enable hald, and frankly I was very reluctant too, but the only way I was able to get around this permissions problem was by enabling hald. My efforts at using autofs with kde on FreeBSD were less than successful, although I'm supposing that autofs probably works just fine on other systems. At one point, it seemed to have crashed my 1TB usb drive, *gasp*, but thankfully it was okay after a reboot.

If I copy a file cp ~/test /media/stick/test, there is no error; that's what made me think it is a filemanager thing.
When I used the plain cp syntax, I got no errors, but when I used the cp -p syntax, I did get the permissions errors. File managers seem to be using the -p option, which is perfect for *nix-style systems, but not such a great thing for those old-school fat32 systems.
 
OP
OP
R

romanaOne

Member

Reaction score: 9
Messages: 78

I still use HAL because it seems to be the only way to get my older wacom tablet to work properly. I say "seems" because I really don't understand how HAL, dbus, udev, devd, and the various DE-specific-console-kit-whatever work or what conflicts.

devel/kf5-solid now has the option to use something called sysutils/bsdisks. I've been trying it out for a few days now and it seems to work well enough with USB flash sticks. It does not seem to conflict with HAL which I left enabled. Dolphin won't touch optical drives, though. Don't know whether that is a bsdisks/KDE problem or, more likely, I goofed something up in the quagmire that is /etc. I use optical media so seldom that I can live with just mounting it manually.
 

Vull

Active Member

Reaction score: 93
Messages: 224

I was planning to try DSBMD again, I'm probably doing something wrong, but should probably try this bsdisks alternative too. For the time being I think I can live with HAL, as long as it's getting the job done, and not threatening to eat any of my long term storage drives. Ample testing with throw-away data on small thumb drives is definitely in order this time around. And I only have one machine left that still has a working optical drive.

Was gladdened to see that the -o large option is being deprecated in FreeBSD-12. It's about time.
 

Vull

Active Member

Reaction score: 93
Messages: 224

I still use HAL because it seems to be the only way to get my older wacom tablet to work properly. I say "seems" because I really don't understand how HAL, dbus, udev, devd, and the various DE-specific-console-kit-whatever work or what conflicts.

devel/kf5-solid now has the option to use something called sysutils/bsdisks. I've been trying it out for a few days now and it seems to work well enough with USB flash sticks. It does not seem to conflict with HAL which I left enabled. Dolphin won't touch optical drives, though. Don't know whether that is a bsdisks/KDE problem or, more likely, I goofed something up in the quagmire that is /etc. I use optical media so seldom that I can live with just mounting it manually.
I was unable to get bsdisks to work, but this 2017 post by krasnij offers an alternative method which seems to have solved the problem at least to my satisfaction:

https://forums.freebsd.org/threads/permission-denied-with-automounted-usb.60534/#post-349831

So I've backed the changes out of /etc/auto_master. All I have in /usr/local/etc/automount.conf is just these few lines:

Code:
USERUMOUNT=YES
ATIME=NO
REMOVEDIRS=YES
USER=vull
I still have to close dolphin before I can eject the drive, which I can now do from my non-root account with the command umount /dev/da0s1. All the USB files are now owned by my user account rather than by root. Dolphin is providing notification when the copy operation is completed, and, perhaps best of all, I no longer require HAL for anything I'm doing.
 
Top