[MacOSX] Please help FreeBSD experts, you are my only hope!

hardtofin

New Member


Messages: 1

Hi guys,

I have the following problem:

I wonder if you good people can help me, i know its not strictly a BSD problem, but i feel like i need the help of a linux boffin. I have a 2 year old imac that was working fine until last night running OSX Leopard.

When i booted my computer last night i got to my desktop but instead of seeing my usual 3 partitions (macintosh, home, windows xp) I only saw 2 - windows xp was missing. Not only this but my system was continuously beachballing.

I was unable to force quit so after a few minutes i held in the power button for 4 seconds until it shut down. Upon reboot, i was (and still am) only able to get to the white screen with apple logo that you get on boot up. On this screen you have a little gear spinning round. This spins for some time then just as my computer would usually boot into the O/S, the gear stops and it hangs.

Please can anyone offer me any help with this? So far i have:

Tried diagnostics mode - all diagnostics come back ok, even in extended test

Single user mode - tried FSCK to repair, first time it made changes to drive, after that nothing.

Tried safe mode - wont boot

Tried booting from leopard cd - still hangs in same place

tried booting from tiger on an external hdd - at same place it usually hangs, it kernel panics instead

swapped ram out - exactly the same problem when using someone elses ram

Im out of ideas, any help would really be appreciated. Thanks so much in advance and sorry for such a long first post. I am a regular reader or macrumors, just havent been to the forums before.

Many thanks again

hardtofin

update:

I have removed the video drivers and caches in single user mode. My computer now boots although has no quartz support and has no 3d acceleration.

I still however can not boot from a CD to put a fresh install of OS X on. Do you guys think this was the fault, just bad files in caches, or could it still be hardware?

what i did was as follows in "single user mode":

/sbin/mount -uw /
cd /system/library/extensions
rm -r NVDA*
rm -r ATI*
rm -r GeForce*


any opinions appreciated, and thanks in advance for your help on a problem which i know is not strictly BSD.

thanks,

hardtofin
 

richardpl

Aspiring Daemon

Reaction score: 68
Messages: 841

Could be bad block on hard disk that have exactly hit one of files(inodes actually) that are required for correct system initialization. In such case even fsck could not help or even worse fsck can not reliably detect bad blocks .

It could be also something else but it is hard to debug such problems from remote location.
 

SeanC

Active Member

Reaction score: 7
Messages: 126

I'm disturbed that you can't boot from the install CD. To me, that suggests a hardware problem. Does an Apple install CD do a hardware check that would prevent it from starting the CD boot?

Can you boot a live linux CD, then mount the hard drive?
 
Top