LXDE LXDE and rc.conf

lucas1

Active Member

Reaction score: 2
Messages: 110

Good day.

Tell me how to start LXDE desctop automatically at startup, not through startx.
Code:
gnome_enable="YES"
gdm_enable="YES"
Likewise Gnome.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,268
Messages: 38,773

LXDE doesn't have a display manager. So you're going to need to install one. I personally like x11/slim. But Gnome's GDM (x11/gdm) should work fine too, you just need to install it because it's not part of the x11/lxde-meta meta port. Alternatively, there's also x11/xdm (traditional display manager for X) and x11/sddm KDE's display manager.
 

CuatroTorres

Member
Developer

Reaction score: 38
Messages: 83

Have you installed GDM?
At least LightDM recognizes the session for Xfce, I'm not sure about this for LXDE and GDM.
You should look at ~/.xinitrc or search for a template within /usr/local/share/doc/gdm... or something.

EDIT: By the way, does SLiM look abandoned? I recommend LightDM, it's also easy customizable.
pkg install lightdm lightdm-gtk-greeter lightdm-gtk-greeter-settings
sysrc lightdm_enable=YES
 
OP
L

lucas1

Active Member

Reaction score: 2
Messages: 110

I will clarify.
No matter what display manager.
How do I tie any display manager with LXDE desktop for all users?

I just gave an example for Gnome in rc.conf.

without ~/.xinitrc file for each user.

Now After entering username and password starts up Gnome3.
And is created file ~/.dmrc:

[Desktop]
Session=gnome
 
OP
L

lucas1

Active Member

Reaction score: 2
Messages: 110

Yes, but LXDE it does not start after DM, but it starts Gnome3.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,268
Messages: 38,773

Yes, but LXDE it does not start after DM, but it starts Gnome3.
If you use GDM hit F1 on the login screen. Then you can choose which desktop environment you want to start.
 

CuatroTorres

Member
Developer

Reaction score: 38
Messages: 83

Users F1 don't need.
...does this mean it worked?

I missed your train. Is lxsession installed?, did you try Session=LXDE in .dmrc?
I don't use LXDE, so I offered you my help blindly. I don't know if GDM recognizes sessions other than Gnome. If SirDice's comment has no effect, you can try to look at /usr/local/etc/gdm for the default options, to avoid manual user intervention.
 
OP
L

lucas1

Active Member

Reaction score: 2
Messages: 110

Session=LXDE - this try.

Through startx LXDE works fine.

In general, we need this

gnome_enable="YES"
gdm_enable="YES"

, but only for LXDE.
 

Alexander88207

Aspiring Daemon

Reaction score: 486
Messages: 701

Yes, but LXDE it does not start after DM, but it starts Gnome3.

Do you have tried to change to your LXDE session like this way?

1615487683526.png
 
OP
L

lucas1

Active Member

Reaction score: 2
Messages: 110

Yes, I found the icon Gnome in the upper right corner and from here a similar list Desktops.
Launched LXDE.

How would we edit this list?
To move list items.
 
OP
L

lucas1

Active Member

Reaction score: 2
Messages: 110

And how to enter on Desktop how root?
startx for root worked.
Charlie also does not pass.
There is no need to write about security.
 

CuatroTorres

Member
Developer

Reaction score: 38
Messages: 83

Don't run X as root. Switch to another tty (Ctrl+Alt+F1.. F8, Ctrl+F9 to return to X) and login as root, for a desktop installation add the wheel, operator, and video groups to the user:
EDIT: Follow SirDice's instructions below.
Code:
pw usermod charlie -G wheel,operator,video
exit
Login X again and run the id command to view the user's active groups from the LXDE terminal.
Then run su and enter the root password, now you can run the preferred commands to manage the system, you can even open a file manager from the terminal.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,268
Messages: 38,773

add the wheel, operator, and video groups to the user:
Don't use pw usermod for this. The -G option replaces all secondary groups of that user. pw usermod charlie -G wheel,operator,video replaces all existing secondary groups of that user with wheel, operator and video. Any existing secondary group this user was a member of will get removed. Use pw groupmod to add a user to a group.
Code:
pw groupmod wheel -m charlie
pw groupmod operator -m charlie
pw groupmod video -m charlie
 
OP
L

lucas1

Active Member

Reaction score: 2
Messages: 110

This is all good and perhaps even correct.

But I'm interested how to enable for LightDM "allow GUI root login". Now for root GUI - "your password is incorrect"
Or in any other Display Managers.

In gdm this "allow GUI root login" enable (or enabled), but can't choose Desktop.
 

CuatroTorres

Member
Developer

Reaction score: 38
Messages: 83

Try greeter-show-manual-login=true in /usr/local/etc/lightdm/lightdm.conf, and type root on the session screen. I'm answering this from my phone and I haven't tried it. Restart Lightdm to take the changes.
man /etc/ttys.
 
Top