Solved Low resolution

D

Deleted member 46228

Guest


Okay, so I installed FreeBSD on another machine and installed all need software (driver, DE, etc) but I am getting low resolution when booting it, is 640x480, my machine can support higher one also I don't have the option to increase it.

When typing nano /root/xorg.conf.new it opens empty file.

How can I get to a higher resolution, and please tell me what command to type so that I can give more info .

;D
EDIT: after using nano /etc/X11/xorg.conf this shows up:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 355.11  (root@101i386-quarterly-job-18)  Mon Oct  5 00:38:11 UTC 2015


Section "ServerLayout"
  Identifier  "Layout0"
  Screen  0  "Screen0" 0 0
  InputDevice  "Keyboard0" "CoreKeyboard"
  InputDevice  "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

  # generated from default
  Identifier  "Mouse0"
  Driver  "mouse"
  Option  "Protocol" "auto"
  Option  "Device" "/dev/sysmouse"
  Option  "Emulate3Buttons" "no"
  Option  "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

  # generated from default
  Identifier  "Keyboard0"
  Driver  "keyboard"
EndSection

Section "Monitor"
  Identifier  "Monitor0"
  VendorName  "Unknown"
  ModelName  "Unknown"
  HorizSync  28.0 - 33.0
  VertRefresh  43.0 - 72.0
  Option  "DPMS"
EndSection

Section "Device"
  Identifier  "Device0"
  Driver  "nvidia"
  VendorName  "NVIDIA Corporation"
EndSection

Section "Screen"
  Identifier  "Screen0"
  Device  "Device0"
  Monitor  "Monitor0"
  DefaultDepth  24
  SubSection  "Display"
  Depth  24
  EndSubSection
EndSection
 

Anjar Wmk

New Member

Reaction score: 1
Messages: 9

Hi Code,
You can place xorg.conf /usr/local/etc/X11/xorg.conf.d/ too if you like.

Did you have run startx and login into desktop, but still getting low resolution?
Perhaps you could check /var/log/Xorg.0.log if something happen.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,348
Messages: 38,870

Try removing the HorizSync and VertRefresh from the monitor section and let EDID do it's thing.
 

protocelt

Daemon

Reaction score: 414
Messages: 1,253

In case you are talking about the console resolution "when" booting, if you are not using a graphics card that uses KMS(which your not as your using Nvidia graphics), you can't change the resolution during boot using the vt(4) console driver. If you want to change the resolution during boot, you'll have to change to the syscons(4) console driver instead. In that case you would use vidcontrol(1) along with the vesa(4) driver to find a video mode your card supports and add it to your /etc/rc.conf file.

For reference: https://www.freebsd.org/doc/handbook/consoles.html
 
OP
D

Deleted member 46228

Guest


Thank you,problem solved by removing HorizSync and VertRefresh ,Cheers!
 
Top