loop in compile

nedry

Active Member

Thanks: 8
Messages: 238

#1
Hi during an attempt to compile port fluxbox i get the following loop:
Code:
Script started on Sat Mar  3 19:41:49 2018
You have mail.
root@bsdbox:/usr/ports/x11-wm/fluxbox # make install clean
===>  License MIT accepted by the user
===>   fluxbox-1.3.7_1 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by fluxbox-1.3.7_1 for building
===>  Extracting for fluxbox-1.3.7_1
=> SHA256 Checksum OK for fluxbox-1.3.7.tar.gz.
=> SHA256 Checksum OK for fb-doc-mfhtml-20060629.tgz.
=> SHA256 Checksum OK for fluxbook-20060629.pdf.
===>  Patching for fluxbox-1.3.7_1
===>  Applying FreeBSD patches for fluxbox-1.3.7_1
===>   fluxbox-1.3.7_1 depends on executable: gmake - found
===>   fluxbox-1.3.7_1 depends on package: pkgconf>=1.3.0_1 - found
===>   fluxbox-1.3.7_1 depends on package: libiconv>=1.14_11 - found
===>   fluxbox-1.3.7_1 depends on file: /usr/local/libdata/pkgconfig/xextproto.pc - found
===>   fluxbox-1.3.7_1 depends on file: /usr/local/libdata/pkgconfig/x11.pc - found
===>   fluxbox-1.3.7_1 depends on file: /usr/local/libdata/pkgconfig/xext.pc - found
===>   fluxbox-1.3.7_1 depends on file: /usr/local/libdata/pkgconfig/xft.pc - found
===>   fluxbox-1.3.7_1 depends on file: /usr/local/libdata/pkgconfig/xpm.pc - found
===>   fluxbox-1.3.7_1 depends on file: /usr/local/libdata/pkgconfig/xrandr.pc - found
===>   fluxbox-1.3.7_1 depends on file: /usr/local/libdata/pkgconfig/xinerama.pc - found
===>   fluxbox-1.3.7_1 depends on file: /usr/local/libdata/pkgconfig/xrender.pc - found
===>   fluxbox-1.3.7_1 depends on shared library: libfribidi.so - found (/usr/local/lib/libfribidi.so)
===>   fluxbox-1.3.7_1 depends on shared library: libfreetype.so - found (/usr/local/lib/libfreetype.so)
===>   fluxbox-1.3.7_1 depends on shared library: libfontconfig.so - found (/usr/local/lib/libfontconfig.so)
===>   fluxbox-1.3.7_1 depends on shared library: libImlib2.so - not found
===>  License imlib2 accepted by the user
===>   imlib2-1.5.0,2 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by imlib2-1.5.0,2 for building
===>  Extracting for imlib2-1.5.0,2
=> SHA256 Checksum OK for imlib2-1.5.0.tar.bz2.
===>  Patching for imlib2-1.5.0,2
===>   imlib2-1.5.0,2 depends on package: pkgconf>=1.3.0_1 - found
===>   imlib2-1.5.0,2 depends on file: /usr/local/libdata/pkgconfig/x11.pc - found
===>   imlib2-1.5.0,2 depends on file: /usr/local/libdata/pkgconfig/sm.pc - found
===>   imlib2-1.5.0,2 depends on file: /usr/local/libdata/pkgconfig/xcb.pc - found
===>   imlib2-1.5.0,2 depends on file: /usr/local/libdata/pkgconfig/xext.pc - found
===>   imlib2-1.5.0,2 depends on shared library: libfreetype.so - found (/usr/local/lib/libfreetype.so)
===>   imlib2-1.5.0,2 depends on shared library: libgif.so - not found
===>  License MIT accepted by the user
===>   giflib-5.1.4 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by giflib-5.1.4 for building
===>  Extracting for giflib-5.1.4
=> SHA256 Checksum OK for giflib-5.1.4.tar.bz2.
===>  Patching for giflib-5.1.4
===>  Applying extra patch /usr/ports/graphics/giflib/files/extra-patch-unbundle-reallocarray
===>  Applying FreeBSD patches for giflib-5.1.4
===>   giflib-5.1.4 depends on executable: xmlto - not found
===>  License GPLv2 accepted by the user
===>   xmlto-0.0.28 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by xmlto-0.0.28 for building
===>  Extracting for xmlto-0.0.28
=> SHA256 Checksum OK for xmlto/xmlto-0.0.28.tar.bz2.
=> SHA256 Checksum OK for xmlto/xhtml2fo.xsl.
===>  Patching for xmlto-0.0.28
===>  Applying FreeBSD patches for xmlto-0.0.28
/usr/bin/sed -i '' -e 's/type -t/which/;'  /usr/ports/textproc/xmlto/work/xmlto-0.0.28/format/docbook/epub  /usr/ports/textproc/xmlto/work/xmlto-0.0.28/format/docbook/txt  /usr/ports/textproc/xmlto/work/xmlto-0.0.28/format/fo/dvi  /usr/ports/textproc/xmlto/work/xmlto-0.0.28/format/fo/pdf  /usr/ports/textproc/xmlto/work/xmlto-0.0.28/format/xhtml1/txt
/usr/bin/sed -i.bak -e '/^GEN_MANPAGE/{s/\$</$>/;}' /usr/ports/textproc/xmlto/work/xmlto-0.0.28/Makefile.in
===>   xmlto-0.0.28 depends on file: /usr/local/bin/bash - found
===>   xmlto-0.0.28 depends on file: /usr/local/bin/getopt - found
===>   xmlto-0.0.28 depends on executable: xmllint - found
===>   xmlto-0.0.28 depends on executable: xsltproc - found
===>   xmlto-0.0.28 depends on package: docbook-xsl>0 - found
===>   xmlto-0.0.28 depends on executable: paperconf - found
===>   xmlto-0.0.28 depends on executable: w3m - not found
===>  License w3m accepted by the user
===>   w3m-0.5.3.20180125_1 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by w3m-0.5.3.20180125_1 for building
===>  Extracting for w3m-0.5.3.20180125_1
=> SHA256 Checksum OK for tats-w3m-0.5.3.20180125-a58f37c_GH0.tar.gz.
===>  Patching for w3m-0.5.3.20180125_1
===>   w3m-0.5.3.20180125_1 depends on package: libiconv>=1.14_11 - found
===>   w3m-0.5.3.20180125_1 depends on package: pkgconf>=1.3.0_1 - found
===>   w3m-0.5.3.20180125_1 depends on executable: msgfmt - found
===>   w3m-0.5.3.20180125_1 depends on file: /usr/local/libdata/pkgconfig/x11.pc - found
===>   w3m-0.5.3.20180125_1 depends on package: perl5>=5.24<5.25 - found
===>   w3m-0.5.3.20180125_1 depends on shared library: libgc.so - found (/usr/local/lib/libgc.so)
===>   w3m-0.5.3.20180125_1 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   w3m-0.5.3.20180125_1 depends on shared library: libatk-1.0.so - found (/usr/local/lib/libatk-1.0.so)
===>   w3m-0.5.3.20180125_1 depends on shared library: libgdk_pixbuf-2.0.so - found (/usr/local/lib/libgdk_pixbuf-2.0.so)
===>   w3m-0.5.3.20180125_1 depends on shared library: libglib-2.0.so - found (/usr/local/lib/libglib-2.0.so)
===>   w3m-0.5.3.20180125_1 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   w3m-0.5.3.20180125_1 depends on shared library: libgtk-x11-2.0.so - not found
===>  License LGPL20 accepted by the user
===>   gtk2-2.24.31 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by gtk2-2.24.31 for building
===>  Extracting for gtk2-2.24.31
=> SHA256 Checksum OK for gnome2/gtk+-2.24.31.tar.xz.
===>  Patching for gtk2-2.24.31
===>  Applying FreeBSD patches for gtk2-2.24.31
===>   gtk2-2.24.31 depends on executable: msgfmt - found
===>   gtk2-2.24.31 depends on executable: gmake - found
===>   gtk2-2.24.31 depends on package: pkgconf>=1.3.0_1 - found
===>   gtk2-2.24.31 depends on executable: gtk-update-icon-cache - found
===>   gtk2-2.24.31 depends on executable: g-ir-scanner - found
===>   gtk2-2.24.31 depends on file: /usr/local/libdata/pkgconfig/xext.pc - found
===>   gtk2-2.24.31 depends on file: /usr/local/libdata/pkgconfig/xrender.pc - found
===>   gtk2-2.24.31 depends on file: /usr/local/libdata/pkgconfig/x11.pc - found
===>   gtk2-2.24.31 depends on file: /usr/local/libdata/pkgconfig/xinerama.pc - found
===>   gtk2-2.24.31 depends on file: /usr/local/libdata/pkgconfig/xi.pc - found
===>   gtk2-2.24.31 depends on file: /usr/local/libdata/pkgconfig/xrandr.pc - found
===>   gtk2-2.24.31 depends on file: /usr/local/libdata/pkgconfig/xcursor.pc - found
===>   gtk2-2.24.31 depends on file: /usr/local/libdata/pkgconfig/xfixes.pc - found
===>   gtk2-2.24.31 depends on file: /usr/local/libdata/pkgconfig/xdamage.pc - found
===>   gtk2-2.24.31 depends on file: /usr/local/libdata/pkgconfig/xcomposite.pc - found
===>   gtk2-2.24.31 depends on package: perl5>=5.24<5.25 - found
===>   gtk2-2.24.31 depends on shared library: libcups.so - not found
===>  License GPLv2 LGPL20 accepted by the user
===>   cups-2.2.6 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by cups-2.2.6 for building
===>  Extracting for cups-2.2.6
=> SHA256 Checksum OK for apple-cups-v2.2.6_GH0.tar.gz.
===>  Patching for cups-2.2.6
===>  Applying FreeBSD patches for cups-2.2.6
===>   cups-2.2.6 depends on executable: gmake - found
===>   cups-2.2.6 depends on package: libiconv>=1.14_11 - found
===>   cups-2.2.6 depends on package: pkgconf>=1.3.0_1 - found
===>   cups-2.2.6 depends on shared library: libavahi-client.so - found (/usr/local/lib/libavahi-client.so)
===>   cups-2.2.6 depends on shared library: libdbus-1.so - found (/usr/local/lib/libdbus-1.so)
===>   cups-2.2.6 depends on shared library: libgnutls.so - not found
===>  License GPLv3 LGPL21 accepted by the user
===>   gnutls-3.5.18 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by gnutls-3.5.18 for building
===>  Extracting for gnutls-3.5.18
=> SHA256 Checksum OK for gnutls-3.5.18.tar.xz.
===>  Patching for gnutls-3.5.18
===>  Applying FreeBSD patches for gnutls-3.5.18
===>   gnutls-3.5.18 depends on file: /usr/local/share/certs/ca-root-nss.crt - found
===>   gnutls-3.5.18 depends on executable: gmake - found
===>   gnutls-3.5.18 depends on package: libiconv>=1.14_11 - found
===>   gnutls-3.5.18 depends on executable: makeinfo - found
===>   gnutls-3.5.18 depends on package: pkgconf>=1.3.0_1 - found
===>   gnutls-3.5.18 depends on executable: msgfmt - found
===>   gnutls-3.5.18 depends on shared library: libgmp.so - found (/usr/local/lib/libgmp.so)
===>   gnutls-3.5.18 depends on shared library: libnettle.so - found (/usr/local/lib/libnettle.so)
===>   gnutls-3.5.18 depends on shared library: libtasn1.so - found (/usr/local/lib/libtasn1.so)
===>   gnutls-3.5.18 depends on shared library: libunistring.so - found (/usr/local/lib/libunistring.so)
===>   gnutls-3.5.18 depends on shared library: libunbound.so - not found
===>  License BSD3CLAUSE accepted by the user
===>   unbound-1.6.8_2 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by unbound-1.6.8_2 for building
===>  Extracting for unbound-1.6.8_2
=> SHA256 Checksum OK for unbound-1.6.8.tar.gz.
===>  Patching for unbound-1.6.8_2
===>   unbound-1.6.8_2 depends on executable: swig3.0 - found
===>   unbound-1.6.8_2 depends on executable: autoconf-2.69 - found
===>   unbound-1.6.8_2 depends on executable: autoheader-2.69 - found
===>   unbound-1.6.8_2 depends on executable: autoreconf-2.69 - found
===>   unbound-1.6.8_2 depends on executable: aclocal-1.15 - found
===>   unbound-1.6.8_2 depends on executable: automake-1.15 - found
===>   unbound-1.6.8_2 depends on executable: libtoolize - found
===>   unbound-1.6.8_2 depends on package: pkgconf>=1.3.0_1 - found
===>   unbound-1.6.8_2 depends on file: /usr/local/bin/python2.7 - found
===>   unbound-1.6.8_2 depends on shared library: libexpat.so - found (/usr/local/lib/libexpat.so)
===>   unbound-1.6.8_2 depends on shared library: libldns.so - not found
After unbound it just loops.
 

Attachments

ShelLuser

Son of Beastie

Thanks: 1,415
Messages: 3,073

#2
Did you by any chance try to combine binary packages with ports somewhere in the past? This is often an indication of that, and doing so can lead to big problems.

The issue is simple: binary packages rely on defaults and default package versions whereas building can customize pretty much everything. So it's not uncommon for a binary package to rely on a different version than a build one, even though both rely on the same package. And that can cause conflicts.

My suggestion would be to start trying to sort out the direct build dependencies.

What I usually do is: # portmaster `make build-depends-list | cut -d '/' -f3-` |& tee build.log and see where this leads you. Once done try performing the main build again. For the record, referring to ports-mgmt/portmaster here.

If you don't want to rely on external software then you could consider (note: I'm assuming defaults, so csh for root):

foreach a (`make build-depends-list`), foreach? make -C $a deinstall install clean, foreach? end.

Warning: this could become quite messy though, it's much easier to rely on portmaster.
 
Top