Solved Logging to GNOME from GDM restarts GDM with errors

PenegalECI

New Member


Messages: 5

Hello, there. Hope my post won't contain too much newbie errors.

I'm a FreeBSD newbie trying to configure FreeBSD as my workstation. After a while struggling with video cards, I had a running GNOME with web browser, office suite, etc. After a reboot, GNOME started to refuse to open itself: on the GDM login screen, I enter my password, which is accepted, then, after around 10 seconds with nothing more on the screen than the default GDM grey background and the mouse cursor, GDM restarts, showing me vt briefly, and then again displays the GDM login screen. The only significant change I made to GNOME on the last successful login was adding a GNOME Shell theme, which applied successfully at the time; I tried to remove the theme folder from /usr/local/share/themes/ and reboot, but it didn't work.

When I have the empty grey screen, I have the following repeating line in my logs:
Code:
dbus[616]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.45" (uid=92 pid=1220 comm="gnome-shell --mode=gdm ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.1" (uid=0 pid=690 comm="/usr/local/sbin/console-kit-daemon --no-daemon ")


Unfortunately, I'm not able to understand these lines, nor how they could be linked to the theme change, if this is the source of the problem. If the theme is the source of the problem, how could I tell GNOME to not use the theme anymore without accessing GNOME? If the problem is different, does somebody know what it is?

Hoping you can help me,

Regards.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,383
Messages: 33,987

Try removing the automatic starting of GDM first. Then just test if you can get Gnome working using startx. That would help narrow down the problem. Gnome Shell can be quite finicky, if the slightest thing is out of place it'll fail to load.
 

cpm@

Moderator
Staff member
Moderator
Developer

Reaction score: 948
Messages: 2,140

Can you show us your gsettings get org.gnome.shell.extensions.user-theme name output?

Show the values for these too:

gsettings get org.gnome.desktop.interface gtk-theme
gsettings get org.gnome.desktop.wm.preferences theme
 
OP
PenegalECI

PenegalECI

New Member


Messages: 5

Try removing the automatic starting of GDM first. Then just test if you can get Gnome working using startx. That would help narrow down the problem. Gnome Shell can be quite finicky, if the slightest thing is out of place it'll fail to load.
This started an ugly graphical interface, with 3 terminals and an old style clock; I suspect this is the default X interface.

Can you show us your gsettings get org.gnome.shell.extensions.user-theme name output?

Show the values for these too:

gsettings get org.gnome.desktop.interface gtk-theme
gsettings get org.gnome.desktop.wm.preferences

Code:
penegal@Aethelthryth-FreeBSD ~> gsettings get org.gnome.shell.extensions.user-theme name
''
penegal@Aethelthryth-FreeBSD ~> gsettings get org.gnome.desktop.interface gtk-theme
'Dorian-Theme-Slate-3.18'
penegal@Aethelthryth-FreeBSD ~> gsettings get org.gnome.desktop.wm.preferences
Usage:
  gsettings [--schemadir SCHEMADIR] get SCHEMA[:PATH] KEY

Get the value of KEY

Arguments:
  SCHEMADIR A directory to search for additional schemas
  SCHEMA    The name of the schema
  PATH      The path, for relocatable schemas
  KEY       The key within the schema

I solved the problem, though, while searching the ~/.gnome directory: I don't know why, but my ~ has been chowned to 1000:1000. After chowning it back to my user, GNOME started again. Thanks anyway for your help!
 

cpm@

Moderator
Staff member
Moderator
Developer

Reaction score: 948
Messages: 2,140

Oops! theme KEY was missing in my previous comment :p

PS. I edited comment #3 to fix the command.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,383
Messages: 33,987

I don't know why, but my ~ has been chowned to 1000:1000. After chowning it back to my user, GNOME started again.
ID 1000 is the first free UID the system uses. Usually the first (user) account created on a system has UID 1000 and GID 1000. Did you perhaps create a new user account with the same username?
 
OP
PenegalECI

PenegalECI

New Member


Messages: 5

ID 1000 is the first free UID the system uses. Usually the first (user) account created on a system has UID 1000 and GID 1000. Did you perhaps create a new user account with the same username?
No, I did not; I grepped /etc/passwd to find whose account it could be, but there is none. Being a FreeBSD newbie, I assume one of my many command tries turned wrong and did this inadvertently.
 
Top