Logging through syslogd not working



At the moment I'm trying to configure different services to log through syslog.

An entry located under /usr/local/etc/syslog.d/ which is default included in /etc/syslog.conf looks like this:
*.*     /var/log/openvpn.log

I also have a file in /usr/local/etc/newsyslog.conf.d/ with an entry like:
/var/log/openvpn.log    600     5       100     *       JC

Altough OpenVPN is not logging anything in openvpn.log it looks like this after a day:
Sep 22 18:31:25 vados newsyslog[86822]: logfile first created

Any Ideas? I have a similar configuration for isc-dhcpd server.
Which is also not logging anything with the above entries.
I remember having issues with OpenVPN logging myself, so I eventually resorted to using --log-append and specifying a dedicated logfile, then pointing newsyslog to the OpenVPN pidfile.

Have you tried using #!openvpn? If I read syslog.conf(5) correctly then the option where you only use an exclamation mark is merely there for compatibility purposes, the preferred way is with the hash character. So I can't help wonder if this could be of any influence.
If you look at the default ppp entry in syslog.conf:

*.*                                             /var/log/ppp.log

include                                         /etc/syslog.d
include                                         /usr/local/etc/syslog.d

This should really indicate the #! isn't necessary right?
I tried your suggestion anyway tho with no luck :/.