Solved LOADER.LUA file not found

KenGordon

Active Member

Reaction score: 22
Messages: 201

I have burned at least 6 DVDs of the ISO FreeBSD-12.1-RELEASE-amd64-dvd1.iso, using every iteration of method I can find, and attempting to boot from any of them BEGINS the boot process, but terminates with "?" and "...BOOT\LUA\LOADER.LUA not found", yet examining the distro finds that file and all others.

Anyone else run into this?

The base system I am using is Win10 Pro, latest iteration.

Ken Gordon
 
OP
K

KenGordon

Active Member

Reaction score: 22
Messages: 201

Yesterday, I found a partial solution to the problem for ONE of my computers, my main desktop: in the BIOS, when I activated both "Native Mode" instead of "IDE Mode" for SATA drives, AND activated AHCI for those devices, the bootonly CD I had made, worked. However, the same solution did not work for the other computer, the one in my shop.

However, then my regular Win10 system would not boot, until I reverted the BIOS back to what it was originally.

Today, I am going to only activate "Native Mode" , and NOT ACHI, since from another report here, AHCI may cause problems. I will then report here what my result is.

From the second of those two bug reports above, and from my experiences, it MAY be that something in the distro may have difficulty with some BIOS settings in some computers on how to handle drives, including using a USB-HD.

I am still investigating.

Thanks for the help.

Ken Gordon
 
Last edited:
OP
K

KenGordon

Active Member

Reaction score: 22
Messages: 201

Solved:

Activating both AHCI and Native Mode for the SATA drives in my "upstairs" desktop solved the "...file not found" errors for THAT computer. FreeBSD installed with no issues and is operating correctly.

I then had to modify my Win10 installation to accept AHCI, which is not a difficult matter. All better now.

However, the same solution did NOT work for my shop computer. I am continuing research.

Ken Gordon
 
OP
K

KenGordon

Active Member

Reaction score: 22
Messages: 201

Solved:

For shop computer (also an older Gigabyte mobo) I had to do the above AND disable On board SATA IDE controller.

The key is to enable both SATA AHCI and Native Mode.

Ken Gordon
 

Zagzigger

New Member

Reaction score: 1
Messages: 11

Solved:

For shop computer (also an older Gigabyte mobo) I had to do the above AND disable On board SATA IDE controller.

The key is to enable both SATA AHCI and Native Mode.

Ken Gordon
This is very interesting. Could you please expand a little?
I also have a Gigabyte mobo, and am running into difficulties understanding what you've done in bios.
I understand SATA set to AHCI, but what does "and Native Mode" mean?
Thanks.
 

msplsh

Active Member

Reaction score: 68
Messages: 247

Based on looking at some Gigabyte manuals SATA Native Mode is the opposite of Legacy IDE Mode, so I guess it turns off some sort of IDE emulation.
 
OP
K

KenGordon

Active Member

Reaction score: 22
Messages: 201

Based on looking at some Gigabyte manuals SATA Native Mode is the opposite of Legacy IDE Mode, so I guess it turns off some sort of IDE emulation.
Yes. This is exactly correct. It turns OFF IDE emulation. In order for me to provide the exact details of what I had to do in the BIOS settings, I'll have to go to that computer and look. I'll try to provide as exact details as I can later today. Please standby for a bit.

I had to do the same sort of exercise with this computer, and will look here too. The details are slightly different for each mobo. The one in my computer in my shop is older than the one in my main desktop, but the results are the same.

Ken Gordon
 
OP
K

KenGordon

Active Member

Reaction score: 22
Messages: 201

OK. Here are the exact details of what I had to do with the computer in my ham shack. The computer uses an older Gigabyte mother board.

In the BIOS, go to "INTEGRATED PERIPHERALS", set "SATA ACHI MODE" to "ACHI". Set "SATA PORT 0-3 NATIVE MODE" to "DISABLED". Set "ONBOARD SATA/IDE DEVICE" to "DISABLED".

For THIS computer, I also had to change the CD-ROM drive from the older IDE type to the modern SATA type in order for it to be "seen".

Then, save and reboot the new BIOS settings.

The BIOS settings in my office desktop had to be set to similar settings. That motherboard is also an older Gigabyte board as I mentioned earlier.

After doing the above, installing FreeBSD went forward with no issues. It is operating perfectly and reliably and I am very pleased with it.

Then, since I am also running Win10 Pro on both machines as my secondary opsys, I had to change Win10 so that it sees the HDs, but that was fairly trivial and details are available at multiple places on the web.

As you can imagine, life has taken a drastic change in direction here, and I have been too busy to spend as much time on the forum as I would like. I will give details of what changes in the BIOS I had to make to this computer as soon as I can.

Ken Gordon
 
Top