Solved Linux program gives "kernel too old" message

tingo

Son of Beastie

Reaction score: 638
Messages: 2,544

I'm trying to run a linux program here, but gets this
Code:
tingo@kg-core2$ ~/progs/fpga-toolchain/bin/yosys
FATAL: kernel too old
Abort trap (core dumped)
If I run file on the executable, I get
Code:
/home/tingo/progs/fpga-toolchain/bin/yosys: ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), statically linked,
       BuildID[sha1]=91a7111e7a2f814f7cd04b65375ff67a95250f10, for GNU/Linux 3.2.0, stripped
compat.linux.osrelease is default
Code:
tingo@kg-core2$ sysctl compat.linux.osrelease
compat.linux.osrelease: 2.6.32
and I'm guessing I can't just wishfully change that to a newer kernel number and expect it to "magically" work?
This is on
Code:
tingo@kg-core2$ uname -a
FreeBSD kg-core2.kg4.no 11.4-RELEASE-p3 FreeBSD 11.4-RELEASE-p3 #0: Tue Sep  1 08:22:33 UTC 2020
     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
If anyone wonders why I don't use the yosys in ports / packages, it is because it is complaining about being too old for the code I'm trying to "compile":
Code:
tingo@kg-core2$ gmake ulx3s.bit
bash: verilator: command not found
nextpnr-ecp5 --85k --json blinky.json \
    --lpf ulx3s_v20.lpf \
    --textcfg ulx3s_out.config
Warning: Use of default value for --package is deprecated. Please add '--package CABGA381' to arguments.
Info: Importing module top
Info: Rule checker, verifying imported design
Info: Checksum: 0x7b9364f2

Info: constraining clock net 'clk_25mhz' to 25.00 MHz
Warning:     ignoring unsupported LPF command 'SYSCONFIG CONFIG_IOVOLTAGE=3.3 COMPRESS_CONFIG=ON MCCLK_FREQ=62 MASTER_SPI_PORT=ENABLE SLAVE_SPI_PORT=DISABLE SLAVE_PARALLEL_PORT=DISABLE' (on line 12)

ERROR: Found netlist using legacy-style JSON parameter values, please update your Yosys.
ERROR: Packing design failed.
2 warnings, 2 errors
gmake: *** [Makefile:69: ulx3s_out.config] Error 255
Any ideas on how to run these linux programs?
 
OP
T

tingo

Son of Beastie

Reaction score: 638
Messages: 2,544

Sigh... I should have tried it before posting here
Code:
tingo@kg-core2$ sysctl compat.linux.osrelease
compat.linux.osrelease: 3.2.0
tingo@kg-core2$ ~/progs/fpga-toolchain/bin/yosys -V
Yosys 0.9+3617 (open-tool-forge build) (git sha1 fd306b05, gcc 9.3.0-10ubuntu2 -Os)

Carry on, nothing to see here...
 

olli@

Daemon
Developer

Reaction score: 1,255
Messages: 1,140

compat.linux.osrelease is default
Code:
tingo@kg-core2$ sysctl compat.linux.osrelease
compat.linux.osrelease: 2.6.32
and I'm guessing I can't just wishfully change that to a newer kernel number and expect it to "magically" work?
“Any sufficiently advanced technology is indistinguishable from magic.”
 ― Arthur C. Clarke’s Third Law, from Profiles of the Future

;)
 
OP
T

tingo

Son of Beastie

Reaction score: 638
Messages: 2,544

Yes, but yosys in ports is too old, per my initial message in this thread.
 

Tulkas

New Member


Messages: 3

Oh, sorry, i missed that. Obviously I did not make it until the end of the message :rolleyes:.
The ports' version matches the latest released version on the homepage. I did not see that you're using a development version.
Sorry for the noise.
 
Top