Lenovo ThinkPad Hybrid USB-C with USB-A Dock

jbodenmann

Well-Known Member

Reaction score: 227
Messages: 433

I have a dock from Lenovo named "Lenovo ThinkPad Hybrid USB-C with USB-A Dock".
As per my understanding, this is a Thunderbolt dock with some USB backwards compatibility (there is a simple USB-C to USB-A adapter hanging on one end of the Thunderbolt cable.

I am trying to understand what needs to happen in order to use this dock with FreeBSD (currently I'm on 13.0-RELEASE).

Here's dmesg after plugging the dock into a Thunderbolt port on a Lenovo ThinkPad P2000:
Code:
ugen0.8: <VIA Labs, Inc. USB2.0 Hub> at usbus0
uhub2 on uhub0
uhub2: <VIA Labs, Inc. USB2.0 Hub, class 9/0, rev 2.10/55.43, addr 7> on usbus0
uhub2: MTT enabled
uhub2: 4 ports with 1 removable, self powered
ugen0.9: <VIA Labs, Inc. USB2.0 Hub> at usbus0
uhub3 on uhub2
uhub3: <VIA Labs, Inc. USB2.0 Hub, class 9/0, rev 2.10/55.44, addr 8> on usbus0
uhub3: MTT enabled
uhub_reattach_port: port 3 U1 timeout failed, error=USB_ERR_IOERROR
uhub_reattach_port: port 3 U2 timeout failed, error=USB_ERR_IOERROR
ugen1.2: <VIA Labs, Inc. USB3.1 Hub> at usbus1
uhub4 on uhub1
uhub4: <VIA Labs, Inc. USB3.1 Hub, class 9/0, rev 3.10/55.43, addr 1> on usbus1
uhub3: 4 ports with 3 removable, self powered
ugen0.10: <vendor 0x1a40 USB 2.0 Hub MTT> at usbus0
uhub5 on uhub3
uhub5: <vendor 0x1a40 USB 2.0 Hub MTT, class 9/0, rev 2.00/1.00, addr 9> on usbus0
uhub5: MTT enabled
uhub4: 4 ports with 1 removable, self powered
uhub5: 4 ports with 3 removable, self powered
ugen1.3: <DisplayLink ThinkPad Hybrid USB-C with USB-A Dock> at usbus1
ugen0.11: <Cypress Semiconductor Billboard Device> at usbus0
uhid1 on uhub5
uhid1: <HID Interface> on usbus0
ugen1.4: <Lenovo ThinkPad Lan> at usbus1
ugen1.5: <VIA Labs, Inc. USB3.1 Hub> at usbus1
uhub6 on uhub4
uhub6: <VIA Labs, Inc. USB3.1 Hub, class 9/0, rev 3.10/55.44, addr 4> on usbus1
ng_ubt: HCI command 0xfc05 timed out
uhub6: 4 ports with 3 removable, self powered
uaudio0 on uhub4
uaudio0: <Lenovo USB Audio> on usbus1
uaudio0: Play[0]: 48000 Hz, 6 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Record[0]: 48000 Hz, 2 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: No MIDI sequencer.
pcm6: <USB audio> on uaudio0
uaudio0: No HID volume keys found.

After plugging it in, xrandr still only shows the internal display.
Furthermore, I don't see an ethernet device showing up either.

What's the current state of Thunderbolt support? Is there any hope in getting at the ethernet interface and an external display up and running with this dock?
Is there some command I can or should run? Some kernel module to load? Anything else I'm missing?
 
Top