LDAP authentication local account asking 2 times password

Paul-LKW

Member

Thanks: 1
Messages: 58

#1
Hi All:
Very long time no post on here, recently I just installed and configured FreeBSD with LDAP authentication that success authenticate for LDAP users, however I find the local user need to type 2 times of password !

I am already performed what my search from Google with try_first_pass in /etc/pam.d/sshd
auth sufficient /usr/local/lib/pam_ldap.so no_warn try_first_pass​
after the "try_first_pass" LDAP users could type signal time password, but for lcoal user, eg. root, it still always asking for 2 times typing.

Any idea about this issue and solution(s)?
Thanks in advance.
 
OP
OP
P

Paul-LKW

Member

Thanks: 1
Messages: 58

#2
Finally I find it is solved by disable the /etc/ssh/sshd_config

UsePAM no​

it seems /etc/pam.d/sshd already force the authentication process to use LDAP with pam so if /etc/ssh/sshd_config listed more one time then it perform 2 times authentication.
 
Top